Find the answer to your Linux question:
Results 1 to 4 of 4
Hi folks, PC-1, local machine Debian 5.0 32bit PC-2, remote machine (a virtual machine) host - Ubuntu 9.10 64bit virtualizer - Sun VirtualBox VM - Ubuntu 9.10 64bit (ip-192.168.0.202) On ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    X forwarding - ssh


    Hi folks,

    PC-1, local machine
    Debian 5.0 32bit

    PC-2, remote machine (a virtual machine)
    host - Ubuntu 9.10 64bit
    virtualizer - Sun VirtualBox
    VM - Ubuntu 9.10 64bit (ip-192.168.0.202)

    On local machine running;
    Code:
    $ ssh -XfC -c blowfish satimischser@192.168.0.202 exec gnome-session
    X-session of VM can be forwarded to local machine. Application can be run locally. But the wallpaper of VM disappears, only the top menu bar including icons forwarded.

    Please advise how to fix the problem. TIA

    B.R.
    satimis
    Last edited by satimis; 04-01-2010 at 01:56 PM.

  2. #2
    Just Joined! silvagroup's Avatar
    Join Date
    Oct 2006
    Posts
    17
    Is that the only problem or does your screen for your remote machine not refresh also. If that's also part of the problem turn off compiz on your host and remote and no more problems.

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by silvagroup View Post
    Is that the only problem or does your screen for your remote machine not refresh also. If that's also part of the problem turn off compiz on your host and remote and no more problems.
    Hi,

    Thanks for your advice.

    My interpretation:-
    PC-1 local machine PC OS=debian 5.0 32bit
    PC-2 remote=VM OS=Ubuntu 9.10 64bit

    PC-1 doesn't have compiz running, only metacity
    PC-2 VM also doesn't have compiz running, only metacity

    Whether I need to turn off metacity? TIA

    B.R.
    satimis

  4. #4
    Just Joined! silvagroup's Avatar
    Join Date
    Oct 2006
    Posts
    17
    You could try it. Sounds like a refresh problem, that's why I recommended turning off compiz. Also make sure you are using generic video drivers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •