Find the answer to your Linux question:
Results 1 to 4 of 4
This is just my opinion, why do we need acpi support in the linux kernel? I've had issues with it on almost every system i've loaded linux on. I don't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User hatebreed's Avatar
    Join Date
    May 2010
    Posts
    335

    acpi and linux


    This is just my opinion, why do we need acpi support in the linux kernel? I've had issues with it on almost every system i've loaded linux on. I don't see the point of having something like this in the kernel if it is going to cause issues. What issues you ask, well to start with, I installed Ubuntu on my dual processor system and everything loaded fine but when I got to the desktop I ran top and noticed that I only had one cpu. I did a lot of research and finally found out by going into my log files that it was the acpi that wan't detecting both cpus. So with a little further research I found out that you can put acpi=off in your kernel line in grub, worked perfect. On my laptop I installed Ubuntu and it installed fine but when I got to the desktop I found both my wireless card and network card wouldn't get an ip. So i did the acpi=off again and worked again. So I guess I'm asking, why do we need something in linux that obviously has issues and isn't needed to the os to function? I have yet to get an answer to this question, so if anyone else has an opinion or an answer, let me know.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    It can be used for Suspend and hibernate, CPU thermal temperature and other things. From Linux.org:
    ACPI also has device drivers that control/monitor devices such as a laptop battery
    Linux Online - About ACPI
    So you can see, sometimes you need ACPI. If you have to disable it, perhaps you need to find out why it has to be disabled in the first place.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,993
    Also on the other hand. On my older IBM Thinkpads like with Puppy Linux I need to add acpi=force to the kernel line in /boot/grub/menu.lst because the bios is so old. If I dont add that line. My cpu temp isn't detected in conky. My battery gets no support in conky. And some Puppy distros won't shut down all the way. At least I can confgure acpi to how I want it to work in Linux.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    Linux User hatebreed's Avatar
    Join Date
    May 2010
    Posts
    335
    Well if that's the case then why are there so many issues with it. It's not the distro because i've tried fedora, opensuse, ubuntu, mint, damn small linux, and all have the same issue. I've also tried different kernel versions with no help. the only thing that helps is putting the acpi=off in the kernel line on boot. It's also not just old systems cause I have a laptop that's a year old and had the issues with the wireless and network card in that system. I mean the hybernate and suspend I could care less about but on the laptop it sounds like it's a little more relivent. I've seen alot of issues doing my research through google and there are alot of different issues with alot of different hardware. What would be causing this issue and how can we fix it? I think this is a good issue to discuss and try to come up with a fix as a community. There should be an easy way to fix the issue and possibly pass the info along to maybe get the issue fixed in future kernels. Thanks for the posts everyone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •