Find the answer to your Linux question:
Results 1 to 9 of 9
I've got a hdd that runs redhat on an LVM partition as its bootup os. I'm trying to access that redhat lvm installation with the hdd as an external USB, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2010
    Posts
    5

    Hidden LVM partition on external USB hdd


    I've got a hdd that runs redhat on an LVM partition as its bootup os. I'm trying to access that redhat lvm installation with the hdd as an external USB, but I can't see the LVM partition on fdisk, so I can't get it mounted. I'm very new to Linux, so I'm hoping I'm just mssing something very obvious. Please, can anyone offer any help?

  2. #2
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    I think
    Code:
    fdisk -l
    should list everything, including partitions which are part of LVM. Also try 'lvscan', 'lvs' and 'lvdisplay' for more info on the LVM volumes.
    Stumbling around the 'net:
    www.cloudyuseful.com

  3. #3
    Just Joined!
    Join Date
    May 2010
    Posts
    5
    Thanks for your response. I actually have tried all of these suggestions already. The result is that all commands work as expected if I'm booted into redhat on that drive. Fdisk shows two partitions, one 3.8 gigs, and the other an LVM taking up the rest of the space. However, if I have it connected as an external, I can't even get fdisk -l to show me everything. It is a 65 GB drive and fdisk only shows me a 3.8 gig partition with no files on it. Any other suggestions? I can show fdisk output if needed.

  4. #4
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    If I understand correctly you are trying to access from a different distribution (one which resides on a different disk)? I think you probably don't have the needed programs in this second distro - you probably have to install the lvm2 package. Here's a run-though on how to do this in Ubuntu.

    If this doesn't help, write what distro you're using and the output of fdisk -l, hopefully we'll get somewhere
    Stumbling around the 'net:
    www.cloudyuseful.com

  5. #5
    Just Joined!
    Join Date
    May 2010
    Posts
    5
    That is correct. I'm trying to access it with a live cd. I've tried ubuntu 9.10, puppy Linux 5.01, and knoppix 6.2.1. Knoppix seems to have LVM2 installed, since the commands executed, they just didn't find anything. I've tried fdisk on both the live cd and the redhat LVM partition (in it's native system) and got two different results.

    Fdisk on Redhat on LVM and native system:
    disk /dev/hda: 60.1 GB, 60129542144
    255 heads, 63 sectors/track, 7310 cylinders
    units = cylinders of 16065 * 512 = 8225280 bytes

    device. Boot. Start. End. Blocks. Id. System
    /dev/hda1. *. 1. 13. 104391. 83. Linux
    /dev/hda2. 14. 7310. 58613152+ 8e. Linux LVM

    disk /dev/sdb: 65.5 GB, 65497726976 bytes
    13 heads, 27 sectors/track, 364459 cylinders
    units = cylinders of 351 * 512 = 179712 bytes

    device. Boot. Start. End. Blocks. Id. System
    /dev/sdb1. 1. 20912. 3669984. A9. Netbsd

    please excuse the periods and capitalization. My work pc doesn't connect to this site, so I'm on my iPhone.

    Thanks

  6. #6
    Just Joined!
    Join Date
    Dec 2007
    Posts
    35

    Want to try a reliable Grub boot loading tool?

    If you want an easy way to boot up whatever OS you may have in any hard drive, go to Remove this and "DOT's"developersDOTberliosDOTde, and download the latest .iso file that's labeled as Super_Grub_Disk_hybrid_1.98s1.iso. It has no Grub repair tools, but it is fantastic for finding broken Grub, and it's associated OS. It will boot up whatever you have. It's keeping me out of trouble right now as I'm writing this. My internal Grub got borked by Sabayon Linux, when I installed it. So until I can get the internal PCLOS's Grub fixed, I'll have to use that CDROM to boot up the system.

    Good Luck!

  7. #7
    Just Joined!
    Join Date
    May 2010
    Posts
    5
    I'm trying something new on my own, so sorry if this doesn't exactly line up with the subject of his thread.

    When runnng the lvdisplay command, what does the value for "read ahead sectors" represent? What impact would it have f this value was 0 as opposed to auto?

  8. #8
    Just Joined!
    Join Date
    Dec 2005
    Posts
    2
    I had a similar problem. I had to use pvscan, vgscan and lvscan.

    Scared the heck out of me when I thought I lost my lvms!

  9. #9
    Just Joined!
    Join Date
    May 2010
    Posts
    5
    No luck yet. I've tried a few different distros with the same result, which is what I reported above from fdisk: a 65.5 gig drive with only 3.8 visible as a netbsd partition. I'm really out of ideas. Could it have something to do with the initrd on the system that is booting the drive that somehow makes the lvm partition visible? That might explain why when it is connected as a secondary USB drive, I don't see the lvm, right? Maybe? Sorry, I'm desperate. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •