Find the answer to your Linux question:
Results 1 to 7 of 7
I have a strange problem when mounting a FAT32 partition as vfat. Some directories do not get write permissions while others do. I thought that all permissions on a vfat ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    4

    Directory permissions on FAT32 partition


    I have a strange problem when mounting a FAT32 partition as vfat. Some directories do not get write permissions while others do. I thought that all permissions on a vfat are set according to the mount options, but it's not the case. See the excerpt from mount and ls below. The directory 'Dropbox' does not get write permissions. Any ideas why?

    /dev/sda9 on /windows/D type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0000,utf8=tr ue,uid=1000)

    # ls -la /windows/D/
    total 516
    drwxrwxr-x 9 uschille users 8192 1969-12-31 19:00 .
    drwxr-xr-x 5 root root 4096 2008-10-04 03:16 ..
    dr-xr-xr-x 4 uschille users 8192 2010-05-23 15:12 Dropbox
    drwxrwxr-x 2 uschille users 8192 2004-11-13 22:27 Recycled

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Mount it again using default and umask options only.

    Code:
    su -
    umount /dev/sda9
    mount  -t  vfat  /dev/sda9  /windows/D  -o defaults,umask=0

    If it works, edit entry for /dev/sda9 in /etc/fstab file.
    Code:
    /dev/sda9         /windows/D          vfat      defaults,umask=0  0  0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jul 2010
    Posts
    4
    Hi and thanks for the response. Unfortunately this did not work. I've tried various mount options already. Dropbox never gets write permissions while all the other directories do. How exactly are directory permission determined with vfat, if not by the mount options?

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Windows based filesystems do not preserve file permissions and unlike Linux based filesystems, mount point permission ( chown mount_point ) doesn't work here.

    Have you tried to check write permissions as root users?

    Have you tried to give write privileges to user uschille using chmod command?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jul 2010
    Posts
    4
    Yes, I have tried that without success. What really puzzles me is that the 'Dropbox' directory gets different permissions compared to other directories. As you say, FAT32 does not preserve permissions, so all directories on the filesystem should be mounted with the same permissions under Linux, shouldn't they? Any clue? Thanks again.

  7. #6
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Have you tried to change the permissions on that directory alone?
    FAT file systems support only four attributes System Hidden
    Read only
    and Archive
    Check that it isn't set to System or Read only

    I'm not sure how Linux handles these Attributes, but you
    should be able to check why this one directory is different.

  8. #7
    Just Joined!
    Join Date
    Jul 2010
    Posts
    4
    I was able to change the permissions using a Linux Live DVD. I still do not understand why just this one directory was different. Anyway, it works now. Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •