Find the answer to your Linux question:
Results 1 to 6 of 6
Moderator Note: Split from tutorial @ http://www.linuxforums.org/forum/topic-26510.html Interesting time for this topic to arise - I was Googling for good answers to this on a week or so ago. I've ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Seattle, WA
    Posts
    2

    mount usb flash drive


    Moderator Note: Split from tutorial @ http://www.linuxforums.org/forum/topic-26510.html

    Interesting time for this topic to arise - I was Googling for good answers to this on a week or so ago.

    I've tried all manner of editing fstab (including the entry shown in this thread). The amazing thing is, whenever I add this (or similar) line(s) to fstab, then my floppy and cdrom drives are no longer shown on my desktop (if you can't tell, I come from the World of Windows and am figuring out how to move into the Land of Linux).

    The main answer in this thread stated that both the mount command and the fstab entry would work under Mandrake 9.x and 10.0. Well, I've chosen Mandrake 10.1 as my instrument of frustration, and it seems to be a little different.

    As one of my early means of attempting to figure out the proper path of my flash drive, I checked the listed hardware using the little GUI under Confound Your Computer. It showed the flash disk perfectly listed - right down to the manufacturer. I found this listed under Hardrives/SDA.

    There was an interesting line contained within the description:

    "Old Devise File: /dev/sda
    New devfs devise: /dev/scsi/host0/bus0/target0/lun0/disc"

    (yes I did attempt a "dev=..." in fstab - but, perhaps I need to explore that some more.)

    Suffice is to say, ls /dev shows no subdirectory of scsi.

    Furthermore, ls /dev shows both sba and sba1 in gold letters with a black background (I haven't figured out what that color scheme means yet, but, I think it is probably telling the system do one thing or another - I would gather this as "cat /dev/sda" proved an interesting experience for a newbie - wish I could understand that code that never seemed to stop scrolling - lol.)

    Yes, I've added the line "none /proc/bus/usb usbfs defaults 0 0" to fstab - perhaps that was an error, though, it didn't seem to break anything (yet).

    Perhaps I need a line refering to the devfs?

    Who knows - at least, I've not a clue after many hours of trying.

    Any suggestions would be greatly appreciated.

    Regards,

    Kurt

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Hi kpep01

    first idd like you to give us your reading

    in terminal
    type
    cd /
    su
    cd /mnt
    fdisk -l
    and give us the line where your USB is listed

    also give us your fstab line please
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342
    There's been a discussion right here inside this forum about mounting USB sticks. Browse the forum and you will find it.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2004
    Location
    Seattle, WA
    Posts
    2
    Follow Up to my first response to the main points queried:

    Since sda1 no longer appeared under device (whereas it once had appeared) I was determined to get it back. This is when I found something interesting that might help in the troubleshooting dept.

    I tried (the tried and true Windows procedure) of rebooting (taboo under Linux). Didn't work, of course.

    I tried unplugging the SanDisk and plugging it back in - still no go. (Windows techniques suck under Linux, and for a good reason I'm sure - the learning curve is still in front of me.)

    Then I tried something I learned from another site...

    #fdisk /dev/sda

    Bingo

    Command (m for help): p

    Disk /dev/sda: 256Mb 256901120 bytes
    16 heads, 32 sectors/tracks, 980 cylinders
    Units = cylinders of 512*512 = 262144 bytes

    /dev/sda1 * 1 979 250608 6 fat16

    Command (m for help): q

    root# ls /dev
    (sba1 shows up again - still gold type with black background)

    root# cd /mnt
    mnt# fdisk -l

    (Lines added to earlier response were the same as shown above in this update.)

    Go Figure?

    The system seems not to want to recognize the flash drive until I entered the fdisk /dev/sda command.

    I hope this helps in the troubleshooting process. Lord Knows I need to learn to troubleshoot Linux as well as I can Windows (and since Windows is for Dummies, it's not to hard to keep the system running despite Mr Bill.)

    fstab remains as I previously mentioned.

    With My Respect,

    Kurt

  6. #5
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342
    I just re installed linux and i can't mount my usbstick like i had it before. The mount point is done cause i can see the files inside the usbstick, but i can't read or write to it. Here's the fstab line for the usbstick.

    Code:
    /dev/sda1 /mnt/usbstick vfat auto,users,rw,umask=0 0 0
    I don't know what i did different. I'll just google it to check it out. But if you can help me out, you know like really fast, that would be great. Off to google then!!

    I am trying to copy some files i need to pass to my brother, running XP, but the error message pops up saying: "Could not change permissions for /mnt/usbstick/name_of_file". WTF mates?

  7. #6
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    try reformatting it with fdisk. I had a simlar problem recently when the filesystem was partially corrupted.

    BTW, "cat /dev/sda" output indicates that it could read you're drive, that data scrolling was the direct output of reading the drive.
    Remember that entries in /dev are just device entries, so cat ing them just outputs what's on that drive. I guess that's an easy way to back up a drive though- just output everything to a file with "cat /dev/sda > $HOME/flashbackup"
    Emotions are the key to the soul.
    Registered Linux User #375050

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •