Find the answer to your Linux question:
Results 1 to 3 of 3
I get this problem for a week now and I almost tried everything ! every 5 min time skip 5 min and after 5 min it rewind 5 min !!! ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    2

    [SOLVED] the clock keeps changing time


    I get this problem for a week now and I almost tried everything !
    every 5 min time skip 5 min and after 5 min it rewind 5 min !!!

    root@lvps212:~# while :; do sleep 2; date; done
    Mon Jun 6 06:29:02 GMT 2011
    Mon Jun 6 06:29:04 GMT 2011
    Mon Jun 6 06:29:06 GMT 2011
    Mon Jun 6 06:34:08 GMT 2011
    Mon Jun 6 06:34:10 GMT 2011

    and after 5 min it will be back 5 min !!!
    can some one point me to the problem please!!

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,914
    Are you running this in a virtual machine? Do you have a setting in the virtual machine for keeping the clock synchronized with the host, and at the same time using NTP (Network Time Protocol) to keep your computer time up to date with the Internet?

    You don't have two different NTP services running do you, conflicting with each other? You could have a system service and also be doing clock sync through the desktop (if your desktop environment supports it).

    The clock works smoothly at other times? The time remains correct if the computer is turned off (the clock keeps running if you're plugged in or if your computer has a bios battery with power in it). Does it do this if you boot into an alternative operating system?
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    2
    thanks for your reply
    I forgot to say its an ubuntu vps and it seems it was system clock problem
    i contacted support and they solve the issue

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •