Find the answer to your Linux question:
Results 1 to 3 of 3
Hi friends! I have a problem with Windows partition. When I boot my laptop with a LiveCD (Wifislax from LFS), I can't write into windows partition, located to /mnt/sda1. But ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    104

    can't write to windows partition


    Hi friends! I have a problem with Windows partition. When I boot my laptop with a LiveCD (Wifislax from LFS), I can't write into windows partition, located to /mnt/sda1. But I have installed on my laptop Ubuntu, and it allows me to write in the Windows partition.
    Why I can't write on the Windows partition with the LiveCD??

    Thank you very much!!!!

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It looks like LiveCD is not using ntfs-3g while mounting NTFS Partition. Other reason could be root privileges.
    Have you tried to write in NTFS partition as root user? In case it doesn't work, gain root privileges through sudo or su and try to mount sda1 again.

    Code:
    sudo umount /dev/sda1
    sudo mount -t ntfs-3g  /dev/sda1  /mnt/sda1 -o defaults,umask=0
    Try to create folder or file in /mnt/sda1.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    104
    Hi!!! It worked!! thank you very much. I have discovered you can use this command too

    mount.ntfs-3g /dev/sda1 /mnt/sda1

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •