Find the answer to your Linux question:
Results 1 to 4 of 4
Hello linux users, I'm in a bit of a bind. I was having trouble with an Ubuntu installation upgrade that left my system crippled, so I decided to change over ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    2

    Angry Cannot restore data backed up in USB drive.


    Hello linux users,

    I'm in a bit of a bind. I was having trouble with an Ubuntu installation upgrade that left my system crippled, so I decided to change over to OpenSUSE.

    The problem I'm having is with how I choose to back up the data.

    The Problem.

    I only had one USB drive available, but it was formatted with NTFS. I tried backing up my data directly to it, but the Ubuntu system began giving me I/O buffer errors. At a first Google glance, I got the general impression that this seemed to be a distribution problem that came up when one made excessive demands on the duress of the transfer. I was backing up over 100 gigs of data from an ext3/4 filesystem to an NTFS, and I was trying to do it from a console on my crippled Ubuntu system, so I just assumed it could have been any number of things.

    Since backing up data into the drive didn't seem to work, I tried running chkdsk /F on the drive from my Windows partition. It began taking a ridiculous amount of time, and it kept coming up with read errors, but I still kept chalking it up to the possibility that the filesystem had become corrupted. You can probably tell where this is going.

    I eventually reformatted the drive into ext4, and tried backing up all of my files from an OpenSUSE LIVE session. It gave me no error so I foolishly assumed that transfer had gone well. Now, I'm trying to copy back the files and it keeps giving me input/output errors. The hard drive was bad but since it gave me no error during the write operation, I had just assumed it had gone flawlessly. The drive itself isn't making any noises, it hadn't given me any problems before. Since I ran chkdsk I would have half expected that any bad sectors would have been invalidated, but that was a short-sighted expectation.

    So, what to do?

    Now, I'm stuck trying to figure if there's anything I can do to salvage it.

    I'm principally concerned about two files, each of which is 32 GB, but I'm not certain I can restore them from the original hardrive given that I've repartitioned, reinstalled, and have already tried to restore my files there. The only option is to keep trying to restore them from the USB. These files are also encrypted.

    I only wish I had had the resources to create a decent RAID backup solution instead of relying on the half-assed backup attempts where I failed to even confirm the data had been correctly backed up after doing so.

    I'm also beginning to question if I should continue to stay with any linux distribution. I'm largely to blame from this failure, but like most failures, it has been promoted by a series of deficiencies between the surrounding environment. I'm going to try reformatting the drive to NTFS, and copying files to it to see if Windows would have noticed the drive was bad just for laughs. Windows would certainly require much less maintenance, and I haven't had the repeated degree of problems I've had during distribution upgrades in Ubuntu and OpenSUSE. Maybe I'm just not cut out for the upkeep a Linux distribution requires.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hello and Welcome.
    My first guess is, you might be out of luck here. But if it's worth a shot to you, I suggest that you get parted magic and use photorec and testdisk (part of parted magic) to try and recover those files. Good Luck.
    start
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    I hope you get your data back, I know how you feel. Yes, your drive sounds like its seen the end of days (or darn near them).

    Hopefully, Mike's suggestion will work for you. If not, I've had luck with System Rescue CD in the past when I've had to salvage data from a bad drive. In particular, it includes TestDisk (the same that Mike mentions above) and ddrescue.

    Bad drives go south in all operating systems. Most Linux distros do come with various daemons and utilities that monitor hard drive health. One that is ubiquitous is smartctl utility form the smartmontools package.

    good luck!

  4. #4
    Just Joined!
    Join Date
    Jan 2012
    Posts
    2
    At least I've had some luck. The two 32GB files that I wanted to restore were truecrypt files, and even though they were not wholly intact, they weren't full either. A large portion of the sectors remained accessible, and I was able to mount them directly from the drive and copy the contents out with no problem.

    Oh, and thanks for the help & suggestions. I'm much less worried, having been able to access the content of these two files, so now I'll just have to weigh in whether the files that returned error on copy merit using the rescue methods you guys have suggested.
    Last edited by phazenator; 01-20-2012 at 12:32 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •