Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm not able to send email using git send-email feature. I've installed git and git-send-email packages and now i need to send patches using git send-email feature. While trying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! amit4g's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore,India
    Posts
    63

    Need help: git configuration for sending emails


    Hi,

    I'm not able to send email using git send-email feature. I've installed git and git-send-email packages and now i need to send patches using git send-email feature. While trying to do so I get following error message:

    "5.7.0 Must issue a STARTTLS command first."

    Some information regarding my setup:
    slackjaw@swamp:~/linux-next$ cat /etc/issue
    Ubuntu 11.10 \n \l

    slackjaw@swamp:~/linux-next$ cat ~/.gitconfig
    [user]
    name = Amit
    email = <XYZ@xyz.com>
    [sendemail]
    smtpserver = smtp.googlemail.com

    git command to send patch:
    slackjaw@swamp:~/linux-next$ git send-email --to "abc@xyz.com" 0001-Adding-debugging-level-for-printk.patch

    The above command returns with error message as mentioned above. Thank you for your help.

    -Amit

    P.S.
    I'm able to send and receive mails when I use thunderbird's default settings which means that there is no issue with the port number or the authentication method for the outgoing mails.

  2. #2
    Just Joined!
    Join Date
    Mar 2012
    Posts
    2

    Git config file incomplete

    Quote Originally Posted by amit4g View Post
    Hi,

    I'm not able to send email using git send-email feature. I've installed git and git-send-email packages and now i need to send patches using git send-email feature. While trying to do so I get following error message:

    "5.7.0 Must issue a STARTTLS command first."

    Some information regarding my setup:
    slackjaw@swamp:~/linux-next$ cat /etc/issue
    Ubuntu 11.10 \n \l

    slackjaw@swamp:~/linux-next$ cat ~/.gitconfig
    [user]
    name = Amit
    email = <XYZ@xyz.com>
    [sendemail]
    smtpserver = smtp.googlemail.com

    git command to send patch:
    slackjaw@swamp:~/linux-next$ git send-email --to "abc@xyz.com" 0001-Adding-debugging-level-for-printk.patch

    The above command returns with error message as mentioned above. Thank you for your help.

    -Amit


    P.S.
    I'm able to send and receive mails when I use thunderbird's default settings which means that there is no issue with the port number or the authentication method for the outgoing mails.
    Hey Amit,

    I think your git config is not complete. Not sure if this solves your problem, but you can give it a try.

    Sample config file for git [taken from a blog of B V Satyaram, as I can not post url as of now]

    [user]
    name = Shailendra Kumar
    email = skr@gmail.com
    [core]
    editor = vim
    whitespace = fix,-indent-with-non-tab,trailing-space,cr-at-eol
    [sendemail]
    smtpencryption = tls
    smtpserver = smtp.gmail.com
    smtpuser = skr@gmail.com
    smtppass = password
    smtpserverport = 587
    to = git@vger.kernel.org
    [web]
    browser = google-chrome
    [rerere]
    enabled = 1
    autoupdate = 1
    [alias]
    s = status
    sb = status -s -b
    #############
    sa = stash apply
    sc = stash clear
    sd = stash drop
    sl = stash list
    sp = stash pop
    ss = stash save
    #############
    d = diff
    dc = diff --cached
    dk = diff --check
    dck = diff --cached --check
    #############
    c = commit
    ca = commit -a
    cm = commit -m
    cam = commit -am
    cd = commit --amend
    cad = commit -a --amend
    #############
    a = add .
    #############
    ap = apply
    as = apply --stat
    ac = apply --check
    #############
    l = log --oneline
    lg = log --oneline --graph --decorate
    #############
    o = checkout
    ob = checkout -b
    #############
    b = branch
    ba = branch -a
    bd = branch -d
    br = branch -r
    #############
    f = fetch
    fo = fetch origin
    #############
    fp = format-patch
    #############
    fk = fsck
    #############
    m = merge
    #############
    pr = prune -v
    #############
    ps = push
    pl = pull
    pb = pull --rebase
    psf = push -f
    psu = push -u
    plu = pull -u
    pso = push origin
    plo = pull origin
    pbo = pull --rebase origin
    psfo = push -f origin
    psuo = push -u origin
    pluo = pull -u origin
    #############
    rb = rebase
    #############
    re = reset
    rh = reset HEAD
    reh = reset --hard
    rem = reset --mixed
    res = reset --soft
    rehh = reset --hard HEAD
    remh = reset --mixed HEAD
    resh = reset --soft HEAD
    #############
    r = remote
    ra = remote add
    rm = remote rm
    rv = remote -v
    rp = remote prune
    rs = remote show
    rso = remote show origin
    rpo = remote prune origin
    #############
    w = show
    #############
    meldon = config diff.external /home/kshailendra/.meld.py
    meldof = config --remove-section diff
    #############
    human = name-rev --name-only --refs=refs/heads/*
    [color]
    ui = true
    [color "branch"]
    current = yellow bold
    local = green bold
    remote = cyan bold
    [color "diff"]
    meta = yellow bold
    frag = magenta bold
    old = red bold
    new = green bold
    whitespace = red reverse
    [color "status"]
    added = green bold
    changed = yellow bold
    untracked = red bold
    [github]
    user = kshailendra
    token = token

    Here your concern seems to be secured connection to smtp server. So setting smtp server port to 587 should help. Do let me know, if it works
    Last edited by shailendrakumar; 03-13-2012 at 06:24 PM.

  3. #3
    Just Joined! amit4g's Avatar
    Join Date
    Feb 2007
    Location
    Bangalore,India
    Posts
    63
    Thank You so much shailendrakumar, After adding following entries under sendmail directive, it worked

    smtpencryption = tls
    smtpserver = smtp.gmail.com
    smtpserverport = 587

  4. #4
    Just Joined!
    Join Date
    Mar 2012
    Posts
    2
    Quote Originally Posted by amit4g View Post
    Thank You so much shailendrakumar, After adding following entries under sendmail directive, it worked

    smtpencryption = tls
    smtpserver = smtp.gmail.com
    smtpserverport = 587
    You are most welcome. Glad to know that it worked for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •