I am using FC14. I am mounting the FSDOS formatted disks.

I have installed vxext to handle the vxworks fsdos format.

When I plug the disk in, the system thinks that it is a FAT16 and auto mounts.

I then unmount it and manually mount with vxext.

The problem is that when it tries to mount as a FAT16 it apparently modifies the directory structure and changes some file lengths ( e.g. if I take a working disk plug it into the linux system, let it try to automount, eject it. Then when I plug it back into the vxworks based hardware it automatically finds files whose length and cluster chain no longer match and then deletes them.)

1). How do I disable the auto mounting or force it to mount as a vxext file system.

2). Why is it writing to the disk when it auto mounts?

thanks
robert