Find the answer to your Linux question:
Results 1 to 2 of 2
Morning... A friend of mine who is somewhat new to linux recently downloaded and installed an nVidia driver pkg. (I think it's an mdk distro). Anyway a while later, he ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    1

    Recovering from a munged rpm install


    Morning...

    A friend of mine who is somewhat new to linux recently downloaded and installed an nVidia driver pkg. (I think it's an mdk distro). Anyway a while later, he downlaoded a security update package for his distribution and installed it. It munged his driver install and he asked for help.

    He tried removing the driver and reinstalling it and now he's stuck in a limbo where the system is not sure if the driver is installed. But it's definitely not working right.

    I mailed him and told him to try:

    rpm --rebuilddb first , followed with an rpm -e to see if it fixed it.

    if that failed I suggested he try some of the following switches:
    rpm -Uvh <package> --replacepkgs --replacefiles --installold --allmatches --nodeps --force
    rpm -ev <packagename> --allmatches --nodeps --repackage --force
    My question: Can anyone think of what I may have missed? Or does anyone have an easy solution that I'm not seeing?

    Thanks in advance!

  2. #2
    flw
    flw is offline
    Linux Engineer
    Join Date
    Mar 2003
    Location
    U.S.A.
    Posts
    1,025
    Have him download the rpm again or from another known source thats good to start with. Maybe he has a bad copy of an rpm even its off a CD.
    Dan

    \"Keep your friends close and your enemies even closer\" from The Art of War by Sun Tzu\"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •