Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, Ubuntu 12.04 desktop 64bit external enclosure HD 640G, USB connection (/dev/sdb) I expect using the HD on the external enclosure for storage purpose without partion. The HD has ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,788

    problem on changing owner


    Hi all,

    Ubuntu 12.04 desktop 64bit
    external enclosure HD 640G, USB connection (/dev/sdb)

    I expect using the HD on the external enclosure for storage purpose without partion. The HD has been successfully blanked with dd

    When I ran
    sudo mkfs.vfat /dev/sdb
    it complained not allowing without partition and requesting adding -I

    sudo mkfs.vfat -I /dev/sdb
    it worked adding the FS

    After mounting the external enclosure;
    $ sudo cp test.txt /mnt
    worked without probem but the file is owned by root

    change owner
    $ sudo chown satimis:satimis /mnt/test.txt
    it complained 'permission not allowed'

    Also tried as root without result.

    Whether I must create partition on the external enclosure HD? Can I create a single partition using the whole HD?

    Please advise. TIA

    B.R.
    satimis

  2. #2

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,788
    Hi,

    Thanks for your link

    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •