Find the answer to your Linux question:
Results 1 to 2 of 2
Hey people, first post around here (: On a openSUSE 12.1 box I tried to customize the file to log sshd-related messages. I made the mistake of installing syslog-ng when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Posts
    1

    rsyslog not logging logger messages


    Hey people, first post around here (:

    On a openSUSE 12.1 box I tried to customize the file to log sshd-related messages. I made the mistake of installing syslog-ng when rsyslog was already installed because I first found instructions about doing it with syslog-ng.

    When I found how to do it in rsyslog, I removed syslog-ng but now I've got a weird situation. After some debugging and tons of google, the simplest problem case I could reproduce is this:

    If I run rsyslog with:
    Code:
    /sbin/rsyslogd -c 5 -f /etc/rsyslog.conf
    And then issue a:
    Code:
    logger "hello world"
    The message correctly appears on
    Code:
    /var/log/messages
    But if I run rsyslog with:
    Code:
    systemctl start syslog.service
    And then issue the same logger command, it doesn't show up (among other messages like the sshd-related).

    The rsyslogd command I got it from looking at the output of:
    Code:
    systemctl status syslog.service
    Any ideas on why this behaviour?

    Thanks in advance!

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    hello and welcome!

    the first thing i'd try is looking at how rsyslog is running, when systemctl starts it, and compare that to how u manually start it. so start it via systemctl, then do:

    ps auxww|grep syslog

    perhaps it is not reading the same conf file, or is passing some other parameter.

    also, in case u are running as a reg user, does the logger command not work as root?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •