Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi, I'm using windows and side by side ubuntu, I want to uninstall windows and use linux only, but I'm having a trouble, i use resolution of 1152x864 with a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Location
    New Delhi, India
    Posts
    10

    How to fix refresh rate and monitor resolution.


    Hi, I'm using windows and side by side ubuntu, I want to uninstall windows and use linux only, but I'm having a trouble, i use resolution of 1152x864 with a refresh rate of 60Hz. But in terminal when i type "xrandr" I get this output
    Screen 0: minimum 320 x 200, current 1152 x 864, maximum 8192 x 8192
    VGA1 connected 1152x864+0+0 (normal left inverted right x axis y axis) 306mm x 230mm
    1280x1024 60.0
    1280x960 60.0
    1280x800 74.9 59.8
    1152x864 75.0*
    1280x768 74.9 59.9
    1024x768 85.0 75.1 70.1 60.0 43.5
    832x624 74.6
    800x600 85.1 72.2 75.0 60.3 56.2
    848x480 60.0
    640x480 85.0 72.8 75.0 66.7 60.0
    720x400 85.0 70.1
    640x400 85.1
    640x350 85.1
    as you can see 60Hz is not available for my resolution, But it works with this setting in windows, can i force linux to do so? and I tried 1024x768 on 60Hz it works fine but small, when i use 75Hz of refresh rate, My display becomes crooked, and looks really bad.
    I type this command
    xrandr -s 1152x864 -r 60

    got this output
    Rate 60.0 Hz not available for this size
    and if I'm not sure if i set my settings as i want and it'd change after reboot, Please tell me a permanent solution, Thanks in advance.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to create xorg.conf file and specify Resolutions and Refresh Rates in it?
    Code:
    sudo /etc/X11/xorg.conf
    Add these contents :
    Code:
    Section "Monitor"
             Identifier "Configured Monitor"
             HorizSync 31.5 - 70.0
             VertRefresh 50 - 160
     EndSection
    
    Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "Configured Video Device"
            DefaultDepth 24
            Subsection "Display"
                 Depth 24
                 Modes "1152x864" 
            EndSubsection
    EndSection
    Save file and Reboot machine. In case it doesn't work, remove xorg.conf file.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Mar 2013
    Location
    New Delhi, India
    Posts
    10
    I made xorg.conf, Then pasted the code, But it wasn't working,
    I added modeline in xrandr, and my problem was solved, but it becomes as it is after a reboot.
    Do i have to make any change in kernal? can I do it in actual? Sorry, I'm a newbie don't know too much. Can i run the same commands to add modeline and run at startup? but still it wouldn't help with login screen and will work after log in, I think, am I right?

  4. #4
    Just Joined!
    Join Date
    Mar 2013
    Location
    New Delhi, India
    Posts
    10
    I combined these commands, it works well just have to paste in terminal and press enter. How to run this at startup? I tried to edit rc.local in etc, but isn't working, can i run it just after boot rather than after login?
    Code:
    xrandr --newmode "1152x864_60.00"  81.75  1152 1216 1336 1520  864 867 871 897 -hsync +vsync ; xrandr --addmode VGA1 1152x864_60.00 ; xrandr --output VGA1 --mode 1152x864_60.00

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    2
    try in your xorg.conf

    Code:
    Section "Monitor"
        Identifier  "Configured Monitor"
        Modeline     "1152x864_60.00"  81.75  1152 1216 1336 1520  864 867 871 897 -hsync +vsync
        Option      "PreferredMode"  "1152x864_60.00"
    EndSection

  6. #6
    Just Joined!
    Join Date
    Mar 2013
    Location
    New Delhi, India
    Posts
    10

    resolution problem again ... Please help

    Hii, I'm here again with a new problem, well no need to say that I do not know very much about linux... But i had problem with my display I've solved it, Now I'm getting another problem, have a look.
    : I use resolution of 1152x864, works pretty well, But I works after when i log in, Before log in, it is 1280x1024, Display looks really weird crooked, If i can set it to 1152x864 natively then i'd be awesome, no need to say, There wasn't any xorg.conf in my ubuntu, and i don't think it works, can anyone help?

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried christh's suggestion (Post #5) ?

    * Merged threads.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined!
    Join Date
    Mar 2013
    Location
    New Delhi, India
    Posts
    10
    Yes, sure, I have tried, That wasn't working, That's why i said, xorg.conf doesn't seem to work. Do I have to update it? Just like i update grub menu through terminal?

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You don't have to update anything. You have to reboot machine after editing xorg.conf file. Have you checked contents of /etc/X11/xorg.conf file after reboot? Copy contents of xorg.conf file and post here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #10
    Just Joined!
    Join Date
    Mar 2013
    Location
    New Delhi, India
    Posts
    10
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Monitor"
        Identifier  "Configured Monitor"
        Modeline     "1152x864_75.00"  81.75  1152 1216 1336 1520  864 867 871 897 -hsync +vsync
        Option      "PreferredMode"  "1152x864_75.00"
    EndSection
    This is my xorg.conf, in etc/X11/ I made this file, and pasted stuff what i was suggested, Is it alright?
    My xrandr gives this message if needed.
    Code:
    Screen 0: minimum 320 x 200, current 1152 x 864, maximum 8192 x 8192
    VGA1 connected 1152x864+0+0 (normal left inverted right x axis y axis) 306mm x 230mm
       1280x1024      60.0  
       1280x960       60.0  
       1280x800       74.9     59.8  
       1152x864       75.0* 
       1280x768       74.9     59.9  
       1024x768       85.0     75.1     70.1     60.0     43.5  
       832x624        74.6  
       800x600        85.1     72.2     75.0     60.3     56.2  
       848x480        60.0  
       640x480        85.0     72.8     75.0     66.7     60.0  
       720x400        85.0     70.1  
       640x400        85.1  
       640x350        85.1

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •