Find the answer to your Linux question:
Results 1 to 6 of 6
Just a warning: I am pretty new to Linux. I am not very experienced with it... Two days ago I was trying to install Skyrim on my Ubuntu 12.04. After ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3

    ATI graphic card - Linux distribution suggestion


    Just a warning: I am pretty new to Linux. I am not very experienced with it...

    Two days ago I was trying to install Skyrim on my Ubuntu 12.04. After two days of work the only thing I managed to achieve was to break my Ubuntu. AFAIK installing games is very difficult with ATI card because it is not well supported (?). Is there a Linux distribution you would suggest to me? I will use it for browsing, working (texts) and gaming.

    These are my system settings:

    OS: Microsoft Windows 7 Home Premium
    Version 6.1.7601 Service Pack 1 Build 7601
    Systemdevelopper ASUSTeK Computer Inc.
    Systemmodell G73Jh
    Systemtyp x64-based PC
    Prozessor Intel(R) Core(TM) i7 CPU Q 740 (at) 1.73GHz, 1734 MHz, 4 cores, 8 logic Prozessor
    BIOS-Version/-date American Megatrends Inc. G73Jh.213, 27.01.2011
    SMBIOS-Version 2.6
    system registry C:\Windows\system32
    starting device \Device\HarddiskVolume2
    Hardware abstraction level Version = "6.1.7601.17514"
    installed physical memory (RAM) 8,00 GB
    overall real memory 7,93 GB
    available real memory 5,25 GB
    overall virtual memory 15,9 GB
    available virtual memory 12,3 GB
    size of the swap file 7,93 GB
    swap file C:\pagefile.sys

    I translated these from german, so they might be wrong.

    On Ubuntu 12.04 I experienced some issues. It was kind of slow. If I had more than 4 taps in firefox open, firefox would repeatedly freeze temporarily. Steam would freeze or just close randomly.

    Is there a linux distribution that would fit better to my system? Remember it has to be somewhat beginner friendly...

    Thanks for your help!

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    That summary doesn't tell us what your current ATI video chipset is. The pendulum is very much swinging in ATI/AMD's favour in terms of video support. So here's my experience.

    I use Fedora 19 on my brand new AMD A8 based computer. It has a built-in Radeon HD 7560D chipset, which is so new it's not supported by the Catalyst driver from AMD. And it doesn't need to be - I'm using the 3D accelerated open source driver that comes with Fedora 19 - and it works great.

    My understanding is that you should be careful which version of Catalyst you install as you need to ensure that the one you get supports your particular video chip. The information to help you do this is on the ATI driver downloads section. On Fedora, if you needed the proprietary driver, it is pretty normal to install the rpmfusion repository and install your chosen driver binaries from there - and you have the same choice with nVidia and ATI, you just need to install the right kmod for your video chipset.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3
    Oops you're right. I got the ATI Mobility Radeon HD 5870.

    Ok, so it doesn't really matter which kind of Linux you use?

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    Quote Originally Posted by nexor View Post
    Oops you're right. I got the ATI Mobility Radeon HD 5870.

    Ok, so it doesn't really matter which kind of Linux you use?
    I agree, it doesn't matter as long as you have a driver installed that matches your video card. It's much better to use a Linux distribution you like. If you're feeling adventurous, you could try a few different distributions out - nearly all of them are free to download and use.
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Just Joined!
    Join Date
    Nov 2013
    Posts
    3
    Ok, thank you! I got another question: I got 4 internal hard drives in my laptop. I would like to install Linux onto the last, empty one. But I get a kernel ("you have to load the kernel first")error when I do. I do not get that if I install Linux on the same hard drive as windows. I guess that is this way because Linux tries to boot from an empty hard drive... Any idea how to fix that?

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    I've never seen that error before. Perhaps it's configuring Grub (the bootloader) badly? If you have a pretty old laptop, you might needs boot partition inside the first 8GB of the hard drive. It's been a while since that was necessary, but you might have a _really_ old laptop...
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •