Find the answer to your Linux question:
Results 1 to 9 of 9
hello, I followed this tutorial: Gaming on Linux- Excalibur: Morgana's Revenge v3.0 | Unixmen ... I somehow managed to install a few games. when I am finished installing them the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49

    where did my tar games go?


    hello,

    I followed this tutorial:

    Gaming on Linux- Excalibur: Morgana's Revenge v3.0 | Unixmen...

    I somehow managed to install a few games. when I am finished installing them the games tend to start automatically, then I install another. I just assumed that each game would place an icon somewhere in the application menu. it did not. all the games I installed were tar gz or bz2. I recall two games off the top of my head: 1. astromenace 2. red eclipse

    where did the games go? where does software installed by tar usually go? they must be somewhere in the directory tree. logic would suggest that if I was able to find these two games, I would probably also be able to find any others that I have already installed and choose to install in the future. good tutorial, by the way, I have never been able to install any tar file before this.
    thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    It depends somewhat on the distribution you are using (you neglected to mention that) but there is usually a Menu and sub-menus and one of them should take you to games.

    The simplest way is to open a terminal and type: whereis excalibur. Change excalibur for whatever software you are looking for, bearing in mind that this is case sensitive so if the name of the software is Excalibur and you type in excalibur, you won't get any results. When you extract a tar file, there is almost always a directory with a README or install file which might explain where it is installed.

  3. #3
    Linux Engineer docbop's Avatar
    Join Date
    Nov 2009
    Location
    Woodshed, CA
    Posts
    949
    When you manually install using tarball (.gz or bz2 etc) they typically don't add the software to the menu system. Because they don't know what envirnment they are running in. When you install using one of the package managers like apt-get the installers do check the environment and will add menu items. To find the program you need to know the name of the executable binary there should be info on the site where you got the file or in a readme file. Once you have the name then you can look for it with find command, or the whereis yancek mentioned or I like which command.

    whereis tells all the files using that name are. I usually use the which command first, it shows you which one it will run if you type the command. If which fails it mean the executable is not in a know path, then using whereis will locate the files with that name.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49
    hello yancek,

    here is output from terminal:
    ed@ed-5310S:~$ whereis astromenace
    astromenace:
    ed@ed-5310S:~$ whereis red eclipse
    red: /usr/bin/red /usr/bin/X11/red /usr/share/man/man1/red.1.gz
    eclipse:
    ed@ed-5310S:~$ whereis red\ eclipse
    red eclipse:


    I will look for a readme file.

    thanks


    edit: I am running an updated version of OS4. similar to xubuntu.

  6. #5
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49
    hello docbop,

    here is the terminal output:
    ed@ed-5310S:~$ which astromenace
    ed@ed-5310S:~$ which red\ eclipse
    ed@ed-5310S:~$

    now I am glad I stopped when I did. I was having some success and was tempted to install more, but I don't even know where the files are located. you're right about them not being present in the menu anywhere.

    thanks

  7. #6
    Linux Engineer docbop's Avatar
    Join Date
    Nov 2009
    Location
    Woodshed, CA
    Posts
    949
    Looking at there website they have quite an involvedx install process so hope you followed all the steps.

    The last step is how to add the game to the menu system.

    Code:
    $ ~/AstroMenace/AstroMenace
    Looking at that and what you type you have the name wrong. Remember in Unix world commands are case sensitive so it's AstroMenace not astromenace. From above it should be in a folder in your home directory in a directory called AstroMenace.

  8. #7
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49
    hello docbop,


    if you check the link I posted, you'll notice that it has been shortened by this website. because of this, you are not able to review the tutorial that I followed. this is very important because the tutorial shows the install procedure as well. sorry. I will separate the link and maybe you will be able to find the tutorial.

    Linux Howtos & Tutorials | Unixmen
    gaming-on-linux1131-19-awesome-opensource-games-for-linux/

    I think by this website shortening the link makes the link less vulnerable in some way. correct me if I am wrong. I didn't realize that the link was not directing to the correct location.
    I actually posted at the unixmen website forum, but never got an answer there.

    most of the games were tar. either tar.gz or tar.bz2 (pardon me for lumping them together as 'tar'). the playdeb games I skipped over. I was not interested in playdeb.


    the operating system I am running is a linux distro called OS4, an ubuntu variety with xfce environment.


    I have this folder:
    /home/ed/Downloads/redeclipse-1.4

    I was able to start the game today with this:
    ed@ed-5310S:~$ cd /home/ed/Downloads/redeclipse-1.4/
    ed@ed-5310S:~/Downloads/redeclipse-1.4$ ./redeclipse.sh
    ed@ed-5310S:~/Downloads/redeclipse-1.4$

    I tried a few days ago. but must have done something wrong at that time.



    I tried the which whereis and locate commands with no luck.

    anyway, I am still unable to find the other games. maybe I deleted the files/folders by mistake. I thought programs went to usr/bin when the installation process was complete and they were ready to execute. I checked usr/bin and didn't find any games that I installed.
    I will have to look at the tutorial again. the sourceforge website also suggests other games for you when they see that you are installing games, and I may have installed a couple that are not in the tutorial (one more reason why I would like to know where they go). I got carried away and lost track of what I was doing, and what I installed.

    I believe I did get an answer to my question though. I download software to my /home/ed/Downloads/ folder, so the game files/folders would be either in /home/ed/Downloads/ or /home/ed/


    if I did delete the game folders, could there possibly be files/folders lingering about somewhere wasting space? how could I delete them?

    from now on, when I install tar software, I am going to copy and paste the terminal output to a text file.


    thanks for the reply.

  9. #8
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,205
    I tried the locate commands with no luck
    You might not have it installed maybe. If it can't find the tar and it, the tar, is in /home. Then you deleted is all I can guess if locate is installed. To find out in Ubuntu.

    Code:
    apt-cache policy locate
    If you install it. Remember what I told you at LQ about updating the data base before looking around with locate.

  10. #9
    Just Joined!
    Join Date
    Dec 2008
    Posts
    49
    hello rok,

    sudo updatedb
    Yep, I am pretty sure that I deleted all the files. normally I download stuff to the 'Downloads' directory, and in this case, I did all the installations right there. I did not move anything. I did notice, however, that hidden files were in the /home/ed directory (they start with a .), so sometimes stuff goes there too. /usr/bin is a popular place for executables, but I don't think anything goes there when installed from a tar. I didn't see any of these game files.
    I know for sure that I have the locate command because I just tried to:
    locate ed
    the terminal output went nuts for at least a minute, scrolling all that it found.

    hope you have all pleasant experiences this year on two wheels, rok.
    thanks for the reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •