Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    rsync failed to set times on a file/dir located on SSHFS mountpoint


    Hello,

    i wanted to ask how i need to modify my SSHFS mounting command so it allows rsync to properly sync files with it.

    Currently this is the error i receive:
    INFO: rsync: failed to set times on "/sshfs/mountpoint/file" No such file or directory (2)
    it shows for both files & dirs

    $ mount:
    root@remoteip:/sshfs/mountpoint on /sshfs/mountpoint type fuse.sshfs (rw)

    /etc/fstab:
    root@remoteip:/sshfs/mountpoint /sshfs/mountpoint fuse.sshfs defaults,_netdev 0 0

    initial sshfs command:
    sshfs user@remoteip:/sshfs/mountpoint /remotestorage -o idmap=user,reconnect,ServerAliveInterval=10,Server AliveCountMax=4,nonempty,port=22

    The rsync is called not by mine command but using vzdump utility, so i prefer if i can tweak SSHFS settings instead of rsync as i am unsure if/how to update vzdumps rsync parameters:
    -t, --times preserve modification times
    -O, --omit-dir-times omit directories from --times
    (standalone rsync command works: rsync -av xy /sshfs/mountpoint)

    How can i please mount the SSHFS so the rsync do not complains?

    fuse-sshfs-2.4-1.el6.x86_64
    centos 6

  2. #2
    Linux User
    Join Date
    Jul 2016
    Posts
    443
    Quote Originally Posted by postcd View Post
    Hello,
    i wanted to ask how i need to modify my SSHFS mounting command so it allows rsync to properly sync files with it. Currently this is the error i receive: it shows for both files & dirs

    $ mount:
    root@remoteip:/sshfs/mountpoint on /sshfs/mountpoint type fuse.sshfs (rw)

    /etc/fstab:
    root@remoteip:/sshfs/mountpoint /sshfs/mountpoint fuse.sshfs defaults,_netdev 0 0

    initial sshfs command:
    sshfs user@remoteip:/sshfs/mountpoint /remotestorage -o idmap=user,reconnect,ServerAliveInterval=10,Server AliveCountMax=4,nonempty,port=22

    The rsync is called not by mine command but using vzdump utility, so i prefer if i can tweak SSHFS settings instead of rsync as i am unsure if/how to update vzdumps rsync parameters:
    -t, --times preserve modification times
    -O, --omit-dir-times omit directories from --times
    (standalone rsync command works: rsync -av xy /sshfs/mountpoint)

    How can i please mount the SSHFS so the rsync do not complains?

    fuse-sshfs-2.4-1.el6.x86_64
    centos 6
    wow your stupid.

    you ask about rsync when your actually using vzdump. you spent more time here begging for yet another handout than you could have spent trying to look something up. put "how to use rsync over ssh" into google. look on the openvz forums for how to do what your after. i sure aint going to look things up for you if your too lazy to do it.

    bum.

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    4,087
    Quote Originally Posted by habit View Post
    wow your stupid.
    Yeah. Really helpful. Actually, I think you meant you're stupid. But you'd have to be... no, never mind.

    Quote Originally Posted by habit View Post
    you ask about rsync when your actually using vzdump. you spent more time here begging for yet another handout than you could have spent trying to look something up.
    This user is clearly under the impression that vzdump uses rsync under the hood. I know nothing about these two tools, so I couldn't say. But... I'm not going to put up a post just to slate someone asking a question. If you're not willing to help, perhaps not helping would be better? This forum should be a friendly, welcoming place.
    Linux user #126863 - see http://linuxcounter.net/

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jul 2016
    Posts
    443
    Quote Originally Posted by Roxoff View Post
    Yeah. Really helpful. Actually, I think you meant you're stupid. But you'd have to be... no, never mind.
    not knowing and not caring are different thanks.
    This user is clearly under the impression that vzdump uses rsync under the hood. I know nothing about these two tools, so I couldn't say. But... I'm not going to put up a post just to slate someone asking a question. If you're not willing to help, perhaps not helping would be better? This forum should be a friendly, welcoming place.
    willing to help sure. this guy? why dont you check out the ops posting history? his constant asking for handouts no effort at all, and the ops general attitude in other threads need to factor in to how much help anyone wants to give them.

  6. #5
    Linux Guru
    Join Date
    Dec 2013
    Posts
    2,747
    Quote Originally Posted by postcd View Post
    Hello,

    i wanted to ask how i need to modify my SSHFS mounting command so it allows rsync to properly sync files with it.

    Currently this is the error i receive:

    it shows for both files & dirs

    $ mount:
    root@remoteip:/sshfs/mountpoint on /sshfs/mountpoint type fuse.sshfs (rw)

    /etc/fstab:
    root@remoteip:/sshfs/mountpoint /sshfs/mountpoint fuse.sshfs defaults,_netdev 0 0

    initial sshfs command:
    sshfs user@remoteip:/sshfs/mountpoint /remotestorage -o idmap=user,reconnect,ServerAliveInterval=10,Server AliveCountMax=4,nonempty,port=22

    The rsync is called not by mine command but using vzdump utility, so i prefer if i can tweak SSHFS settings instead of rsync as i am unsure if/how to update vzdumps rsync parameters:
    -t, --times preserve modification times
    -O, --omit-dir-times omit directories from --times
    (standalone rsync command works: rsync -av xy /sshfs/mountpoint)

    How can i please mount the SSHFS so the rsync do not complains?

    fuse-sshfs-2.4-1.el6.x86_64
    centos 6
    i cannot answer directly, all i can say is that
    • sshfs can be tricky with permissions
    • i moved away from sshfs and am using nfs now
    • iirc, rsync can use ssh directly, so you wouldn't even need sshfs at all

  7. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    4,087
    Quote Originally Posted by habit View Post
    not knowing and not caring are different thanks.
    When ripping into someone for being 'stupid', you should ensure that you've not made primary school-grade errors in what you write. I was only pointing out your inconsistency.

    Quote Originally Posted by habit View Post
    willing to help sure. this guy? why dont you check out the ops posting history? his constant asking for handouts no effort at all, and the ops general attitude in other threads need to factor in to how much help anyone wants to give them.
    I'm very aware of this user's history of requests for help, that doesn't mean I'm going to abuse them. I agree that some users are harder to help than others - some just don't seem to be able to resolve issues by searching in the right place. Some can't resolve issues because they're facing a language barrier that's not helping them. But if you don't feel disposed to help, then don't help - but resorting to this unwelcoming attitude really doesn't help the forums.
    Linux user #126863 - see http://linuxcounter.net/

  8. #7
    Linux User
    Join Date
    Jul 2016
    Posts
    443
    Quote Originally Posted by Roxoff View Post
    When ripping into someone for being 'stupid', you should ensure that you've not made primary school-grade errors in what you write. I was only pointing out your inconsistency.
    again; errors = mistakes made without knowing, due to lack of knowledge. and again: not caring != not knowing.
    I'm very aware of this user's history of requests for help, that doesn't mean I'm going to abuse them. I agree that some users are harder to help than others - some just don't seem to be able to resolve issues by searching in the right place. Some can't resolve issues because they're facing a language barrier that's not helping them. But if you don't feel disposed to help, then don't help - but resorting to this unwelcoming attitude really doesn't help the forums.
    harder to help? sorry no. pretty much every single post is something looking for a handout. no effort, no searching, just 'give me exactly what to type in". language barrier? nope, sorry again. he makes himself understood just fine. grammar is one thing. hes plain lazy.

    for example:
    cant read a man page - http://www.linuxforums.org/forum/mis...r-archive.html
    no details wont answer questions - http://www.linuxforums.org/forum/sec...les-t-nat.html

    goes back and forth...asking about the same topic for years, and can never, EVER seem to learn anything. every new command requires a new thread and someone to read the man page for him. be sure to check out his posting history on lq....where he takes all of the answers he gets here and elsewhere and posts them to HIS OWN BOARD as his own. i get what your saying but really? if you use iptables for literally YEARS, you shouldnt have to ask about how to block a new port. you should be able to put just a TINY bit of effort in on your own. hes plain lazy and is even proud of it.
    Last edited by habit; 09-21-2017 at 12:44 PM.

  9. #8
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    4,087
    So don't reply to him. You've made all this effort just to justify your abuse of another forum user? I know this user doesn't help himself, but there's really no need for verbal abuse.
    Linux user #126863 - see http://linuxcounter.net/

  10. #9
    Linux User
    Join Date
    Jul 2016
    Posts
    443
    Quote Originally Posted by Roxoff View Post
    So don't reply to him. You've made all this effort just to justify your abuse of another forum user?
    dont need to 'justify" it. guys like him are everywhere and will keep coming back as long as they get there hands held. if you can think of another way to motivate this bum to do some of his own work then id love to see it, please. youd be doing everyone here and on many other forums a favor.
    I know this user doesn't help himself, but there's really no need for verbal abuse.
    if he doesnt like the answers he can start coming up with better questions. and id gladly not verbally abuse someone who did not do it to me. why dont you ask him about the pms ive received, with much harsher language than things like moron, idiot, and bum in them.

  11. #10
    -->
    OFFTOPIC POST for the Moderator

    Quote Originally Posted by habit View Post
    ask him about the pms ive received, with much harsher language than things like moron..
    This is a public accussation so i respond here making OT. This was roughly one PM for which i apologized to him and here i apologize again. Why i did it? because this person was wearing me down and hurting me in his posts even i told him how i feel about that.
    Ok i am sorry again, i should not be bad to anyone no mater what others do to me.

    Regarding my insufficiently described questions, i am already trying to be more descriptive from the time habit started by unhappy about my topics. If i need to provide more details in particular thread, please kindly let me know the command that shows the needed information.. Thank You

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •