Find the answer to your Linux question:
Results 1 to 6 of 6
Well I installed SuSE 8.1 and I like it but there are some problems which I can't find solutions for. 1) When switching from X to a console using CTRL+ALT+F? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    SuSE 8.1 Issues


    Well I installed SuSE 8.1 and I like it but there are some problems which I can't find solutions for.

    1) When switching from X to a console using CTRL+ALT+F? -> The screen looks garbled and slightly fuzzy - it's readable but it's just not right. I didn't notice this until I installed the Nvidia drivers, at least I don't recall.

    2) When I used to start KDE, there was a sound that would play telling that it was done loading - although in the Kontrol Center it is said to do this, it does not. "artsd" does load fine though.

    3) I've noticed that the entire IDE chain runs in bursts... For example when copying data between drives, or across the same drive, reading or writing a CD from both the Burner and the regular CDROM, it reads or writes a bit, stops, reads or writes a bit, stops... this makes watching VCD's, and Diablo II movies impossible. It also makes my 40x burner seem as though it's burning at around 8x (SUCKY)! And finally, copying 8Gb of music from one drive to another took a REDICULOUSLY long time. This "burst" also renders the system unusable for moments at a time as processor usage climbs to 100% according to TOP.

    Any help for the above items would be most appreciated

    Cole Nielsen

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    1. It's probably due to those nVidia drivers. They are known to be a bit buggy (after all, what can you expect from a closed-source production?). Try re-posting this question on nVidia's support board.

    2. Sorry, can't answer this; I don't use KDE.

    3. There is nothing wrong with the bursts, that's just standard write caching and read-ahead. The problem seems to be that you don't get DMA enabled automatically. It seems that certain IDE chipsets don't get DMA enabled automatically, and I don't know why yet. Verify it with this command:
    Code:
    hdparm -d /dev/hd?

  3. #3
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    hdparm

    It won't allow me to enable DMA for the burner or the CDROM but DMA is already enabled for the hard drive... any other ideas?

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Maybe you have a strange IDE chipset that isn't completely available with the generic driver. Check what you have with /sbin/lspci. Note that if that's the problem, you will need to recompile the kernel to sort it out. Would you be able to do that?

  5. #5
    Linux Newbie
    Join Date
    Jun 2003
    Posts
    160

    Kernel

    I compile in support for my INTEL Chipset... which IS supported under Linux.... how do i recompilie the kernel without breaking the distro???

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    There is very little that you could do to break the distro. Just a few things, though: if you're using DRM for XFree86, make sure to compile the right DRI kernel module for your video card, and I'm guessing that you want AGPGART as well. Also, make sure to compile the correct firewall modules if you're using a such.

    Anyway, before all that, what Intel chipset is it? And even though it is technically supported by Linux, SuSE's kernel might have that support left out of it for any reason. Check what files you have in /proc/ide.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •