Find the answer to your Linux question:
Results 1 to 10 of 10
I just installed Ubuntu (hoary hedgehog) with the minimum options so that it only runs command line. the probel is that when i have to log in as root , ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Toronto
    Posts
    54

    Cant log in as root in Ubuntu


    I just installed Ubuntu (hoary hedgehog) with the minimum options so that it only runs command line. the probel is that when i have to log in as root , it doesnt let me log in.

    here is what i do

    $ sudo su -
    Password: ( i leave this blank as i have no password for root)

    Login Incorrect


    no option came during install to set root password. how do i log i as root?

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I have BeatrIX installed to HD and I ran into the same thing since BeatrIX is based on Ubuntu. I forget the remedy, but you will find the answer in the FAQ on the Ubuntu site. Hope this helps...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    so simple

    just type
    sudo -s
    this is it. u r root now. then u can create a root account.
    smile

  4. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    When sudo asks for your password, it wants your pass on your account, not root password. 'sudo -s' should give you a shell, or you can do 'sudo passwd root'.

  5. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    better solution

    Hi guys,

    I had the same problem, but the above posts gave me the hint I needed:

    This should work nicely:

    sudo su -

    'su -' switches you to to the super user (root) account. The dash means 'run the login scripts'. The sudo is required to give the current user priviledges to use the su - command.

  6. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by valan
    When sudo asks for your password, it wants your pass on your account, not root password. 'sudo -s' should give you a shell, or you can do 'sudo passwd root'.
    This is something that confused me at first as well. To recap, here's what I did to re-enable the root user (note, I mean actually enable the user, not just log in with root privileges):

    1)Type sudo
    2)When it asks for a password, enter your current user's password.
    3)Type passwd root or just passwd.
    4)Enter and confirm the password for the root user.
    5)Now you can actually use the su command, though I haven't figured out how to actually *log in* as root on Ubuntu yet. GDM doesn't seem to want to let you do it.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  7. #7
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Quote Originally Posted by techieMoe
    5)Now you can actually use the su command, though I haven't figured out how to actually *log in* as root on Ubuntu yet. GDM doesn't seem to want to let you do it.
    To enable root login (according to the Ubuntu Guide), do the following:
    1. System -> Administration -> Login Screen Setup
    2. Security Tab -> Options -> Allow root to login with GDM (Checked)

    I haven't actually tried this yet but it sounds like it will work.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #8
    Just Joined!
    Join Date
    Mar 2005
    Location
    UK
    Posts
    7

    cant login, at all

    Hello - Im new to ubuntu..I got some help with previously to change the default user from ubuntu to pcooklin...Now when I cant login at the gdm manager...Ive tried both users, ubuntu and pcooklin but neither work...Ive had some more help trying to reset the password but it hasnt worked..does anyone know how I can get back in to the system?

    Thanks for your time.
    Paul.

  9. #9
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Thumbs up Thanks!!

    Quote Originally Posted by vipertux
    just type
    sudo -s
    this is it. u r root now. then u can create a root account.
    smile
    I've been trying to install a video driver and spend so much time. but the above method saved me.. THANKS!!

  10. #10
    Just Joined!
    Join Date
    May 2007
    Posts
    1

    Logging into the Graphical User interface (GUI)

    BryanSmith's method worked beautifully for me, although there were some details which were different. I have UBUNTU 7.04 Feisty Fawn! installed, and when I navigated through System-->Administration--> Login Window, I was presented with the Login Window Preferences window.On the Security tab I found an empty checkbox labelled 'Allow local system administrator login'. I ticked this box and pressed 'Close'. I had already set a root password xxxxxx as described below, and when I rebooted UBUNTU I only had to enter Username: root and Password: xxxxxx in the opening screen to open UBUNTU with full root privileges.
    To set the password for 'root':- Go to System-->Administration-->Users and Groups. Enter your User password. Select 'root' in the Users settings window and press 'Properties, Set and confirm your new password xxxxxx for root in the Account 'root' Properties window. Press 'OK' and 'Close'.
    Done.
    Ptolemy1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •