Find the answer to your Linux question:
Results 1 to 4 of 4
I have been trying to compile a kernel for 10 days now with no results. Please help. I am trying to compile a kernel that would have SCSI RAID support ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    85

    Linux Kernel config for Raid and SMP


    I have been trying to compile a kernel for 10 days now with no results. Please help. I am trying to compile a kernel that would have SCSI RAID support as well as SMP support for Slackware Linux. After trying to compile the 2.4 kernel with no results I copied the config file from Fedora Core 2 for it's kernel. BTW fedora automatically detects all CPUs and HDs and works grate, but I want to get slackware installed. Anyway, I copied the config file for kernel that works just fine with fedora and compiled a 2.6.11.7 kernel with that config file, installed the modules and restarted the server. The kernel boots and recognizes the RAID device, and the SMP setup, but when it comes time to mount the root partition it gives me an error: can't find the node. I am using the standard /dev/ida/c0d0p1 but also tried /dev/rd/c0d0p1. It does not see any of those!? But the RAID is recognized and "Auto Detected" with no errors. Is there another node that my RAID drive can be associated with? Something else to try? Also, perhaps if you ever compiled a kernel with these specifications can you send me your config file to this email: junk at toleap.com. The system that the kernel is for is Compaq ProLiant 5500.

    Thank you for any help,

    - Bogdan

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saint-Eustache
    Posts
    11

    can't mount raid

    hello I have the same problems as you with a s-ata raid.. it's detect all HDD when auto-detecting detect raid it's finish with no error.. I have compiled a kernel 2.6.11.7 with the support of my raid controller but I cannot mount the HDD....

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    85
    Unfortunately I was never able to resolve the problem. Right now I am running debian, and debian detected everything out of the box and has been running quite well. In fact I am running my websites of the server now and it is going good. I miss slackware, but I just could not go on without a server, so a quick solution won out. If I ever get around to installing Slack on this server, perhaps Slack 11 once it comes out, I will post a How To.

    - Bogdan

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Posts
    85
    Oh yeah, I tried this, not successfully, but it's worth a shot. Try burning a slack 10 cd with your custom kernel on it, then boot the kernel from cd and dig around /dev for the node. I think my problem was that my raid under kernel 2.6 was showing up as /dev/ida/disk0/p1 (i think, something close to that anyway). The only problem is lilo refused to take that node as a parameter. So I actually ended up founding out how to mount the disk under 2.6, but could not install lilo from under 2.4 to boot like that. Any way, Debian it is for me, for now.

    - Bogdan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •