Find the answer to your Linux question:
Results 1 to 9 of 9
I need to be able to use some characters that are not on a US-qwerty keyboard. I know on windows you can do that by pressing "alt + ASCII_code_number". Anyway ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie jeickal's Avatar
    Join Date
    Jan 2005
    Location
    Switzerland
    Posts
    114

    How do you type a character using its ASCII Code?


    I need to be able to use some characters that are not on a US-qwerty keyboard. I know on windows you can do that by pressing "alt + ASCII_code_number".
    Anyway to do this on Gnome 2.6 (Mandriva 10.1)?

    Thanks

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    If I remember right you can add an applet to your panel where you can choose a sign.

  3. #3
    Linux Newbie jeickal's Avatar
    Join Date
    Jan 2005
    Location
    Switzerland
    Posts
    114
    Cool, Thanks, I never noticed it before.
    I can now write in my language without spelling mistake

    Now if someone knows a "keyboard way" to do it (as that'll be faster than having to grab my mouse) I'll give a banana for it

  4. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Well, what exactly are you trying to do?

    For accents, for example, you could simply change your layout to another language that supports such symbols. For example, switching my layout to Spanish makes my keyboard support:



    And so on.

  5. #5
    Linux Newbie jeickal's Avatar
    Join Date
    Jan 2005
    Location
    Switzerland
    Posts
    114
    Ok here is more detail:

    I recently changed my keyboard to a Dvorak layout to improve my typing speed. As it is based on a US keyboard, I lost the ability to type non-US letter, which is OK for most of the time since I mainly work in english. My problem comes when I need to type an email in one of the languages spoken in my country. I don't want to have to change layout every time I need a letter with accent. Now, thanks to jaboua's suggestion I can grab my mouse and click on this gnome applet that contains the letters with accent I need. But this defeat the purpose of having a Dvorak layout if every time I need to type an accent I have to grab my mouse. So I figured I could learn by heart the ASCII code of the extra letters I need that are not on a US keyboard.
    And here I am asking if someone would know a trick to enter the ASCII code (keeping my hands on the keyboard), just like "alt + ASCII_code" in windows.

  6. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    28
    i use another language

    in Gnome

    go to Preferences > Keyboard > Keyboard > Layout > Selected <-> Available Layouts (i see Dvorak), click + Add

    Then go back to Layout Options to switch (i use alt shift) works on the fly

    while you are there, pick out your keyboard, (there is an option preview just to make sure)

  7. #7
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    He's specifically saying he doesn't want to change layouts.

    I understand what you're saying. There's something in Linux called deadkeys that let you do something like what you want. I don't know how to use deadkeys or how to configure them, but if anyone can explain them, it might help.

  8. #8
    Linux Newbie jeickal's Avatar
    Join Date
    Jan 2005
    Location
    Switzerland
    Posts
    114
    Quote Originally Posted by Cabhan
    There's something in Linux called deadkeys that let you do something like what you want. I don't know how to use deadkeys or how to configure them, but if anyone can explain them, it might help.
    Got it working

    Cabhan, despite the fact that you didn't provide the full solution to my problem you pointed me to the right direction. So I thought it's worth one

    For those interested, here is what I found about those "dead keys":
    A dead key is a key that needs to be combined with another one to print a letter with accent for ex: press "apostroph", the cursor doesn't move and nothing appears, then press "e" and you get:
    That's why it's called a dead key as it seems like nothing appends when you press it.
    Now to have this work on my US-style keyboard under Linux, I simply have to use the "compose" key (also called "Alt Gr") and the apostroph, than I press "e" and get my
    Thanks

  9. #9
    Just Joined!
    Join Date
    Jul 2007
    Posts
    1
    If someone here uses KDE instead of GNOME theres a way to improve the keyboard as jeickal said using dead keys. The option is in the KDE Control Center > Regional & Accessibility > Keyboard Layout, once there select the "Xkb Options" tab and in the "Compose Key" group select the key to hit when you need an accent. For example to type an "" hit (in my case the "Compse Key" is Right Alt) "Right Alt + ' > a" and to type a "Right Alt + Shift + ~ > n", that shift because the ~ is in the second level of the key.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •