Find the answer to your Linux question:
Results 1 to 8 of 8
Hi folks, FedoraCore3 If on removing a package-A with # yum remove package-A After finish it is recognised that some other packages also removed together. Is there a "RESTORE" command ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804

    A question on Yum


    Hi folks,

    FedoraCore3

    If on removing a package-A with
    # yum remove package-A

    After finish it is recognised that some other packages also removed together. Is there a "RESTORE" command to rescue. Re-install the deleted package-A could not solve the problem which would not re-install all other deleted packages automatically.

    TIA

    B.R.
    satimis

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    If you open "Add/remove programs" or something similar some place in the menu, you should be able to install the deleted packages again (off the CDs), at least if the deleted packages were packages which came with the system.

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Hi jaboua,

    Tks for your advice.

    I have no problem to find the list of packages deleted automatically which is displayed on the terminal (Konsole). But I have to reinstall them one by one.

    I learnt a bitter lesson before on removing a package with "yum remove package" It remove 90+ packages automatically in addition without asking a question. Therefore I'm looking for some other method of "RESTORE", if possible, instead of reinstalling them one by one.

    B.R.
    satimis

  4. #4
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    What I meant is that if these packages were installed by default, or lies on the CD, you can use the graphical utility "Add/Remove applications" or whatever it was called, select the un-full groups and then the app will take care of installing the files, almost everything at the same time, from the CDs for you. But if you have installed the packages later == not on CDs, then... Also, if yum won't do it, check out APT4RPM which is a port of debians APT working with RPM packages.

  5. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Hi jaboua,

    Tks for your further advice.

    Now I'm clear. You suggested on KDE desktop using
    KStart -> System Settings -> Add/Remove Applications

    to reinstall the packages deleted accidentally.

    There are 2 problems;
    1) It'll take time to sort out those packages deleted
    2) Some of them may be already updated several times

    I could not recall exactly. There is a method keeping all deleted packages in a special directory/folder. They are not actually removed. In case of need you can restore them. After running the PC without problem then you can delete them later.

    I'll take a look on APT4RPM. Tks.

    B.R.
    satimis

  6. #6
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    If there is a method for resotring, I'm pretty sure you will find it if you type "man rpm" in a terminal... Lots of options... Or, for a shorter version, but with less explainations, type "rpm --help" or something similar. In Add/Remove applications, have you tried just selecting every wanted group of packages and letting the app take care of finding which packages you want installed?

  7. #7
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,804
    Hi jaboua,

    Tks for your advice.

    Previously I applied;
    $ rpm -e package

    Later I found
    # yum remove package

    more convenient then I started using it.

    However I learnt a bitter lesson about 2 days ago. I ran

    # yum remove alsa-lib.i386 0:1.0.6-8.FC3

    following packages removed automatically without asking a question;

    Remove: NetworkManager-gnome.i386 0:0.3.4-1.1.0.fc3
    Remove: SDL.i386 0:1.2.7-8
    Remove: SDL_mixer.i386 0:1.2.5-4
    Remove: SDL_mixer-devel.i386 0:1.2.5-4
    Remove: alsa-lib-devel.i386 0:1.0.6-8.FC3
    Remove: alsa-utils.i386 0:1.0.6-3
    Remove: arts.i386 8:1.3.1-1
    Remove: control-center.i386 1:2.8.0-12
    Remove: desktop-printing.i386 0:0.17-3
    Remove: dia.i386 1:0.94-5.fc3
    Remove: eel2.i386 0:2.8.1-2
    Remove: eog.i386 0:2.8.0-3
    Remove: esound.i386 1:0.2.35-2
    Remove: evolution.i386 0:2.0.4-4
    Remove: evolution-data-server.i386 0:1.0.4-3
    Remove: evolution-webcal.i386 0:1.0.10-1
    Remove: file-roller.i386 0:2.8.1-1
    Remove: firefox.i386 0:1.0.4-1.3.1
    Remove: firstboot.noarch 0:1.3.33-1
    Remove: gaim.i386 1:1.3.0-1.fc3
    Remove: gconf-editor.i386 0:2.8.0-2
    Remove: gdm.i386 1:2.6.0.5-6
    Remove: gedit.i386 1:2.8.1-2.fc3.1
    Remove: ggv.i386 0:2.8.0-1
    Remove: gimp.i386 2:2.2.6-0.fc3.2
    Remove: gimp-data-extras.noarch 0:1.2.0-12
    Remove: gimp-gap.i386 0:2.0.2-2
    Remove: gimp-help.noarch 0:2-0.1.0.7.0.fc3.1
    Remove: gimp-print-plugin.i386 0:4.2.7-2
    Remove: gnome-applets.i386 1:2.8.0-5
    Remove: gnome-desktop.i386 0:2.8.0-3
    Remove: gnome-keyring-manager.i386 0:0.0.3-1
    Remove: gnome-media.i386 0:2.8.0-3.FC3.1
    Remove: gnome-netstatus.i386 0:2.8.0-3
    Remove: gnome-panel.i386 0:2.8.1-3
    Remove: gnome-pilot.i386 0:2.0.12-4
    Remove: gnome-python2.i386 0:2.6.0-3
    Remove: gnome-python2-bonobo.i386 0:2.6.0-3
    Remove: gnome-python2-canvas.i386 0:2.6.0-3
    Remove: gnome-python2-gtkhtml2.i386 0:2.6.0-3
    Remove: gnome-session.i386 0:2.8.0-4
    Remove: gnome-spell.i386 0:1.0.5-6
    Remove: gnome-system-monitor.i386 0:2.7.0-2
    Remove: gnome-terminal.i386 0:2.7.3-1
    Remove: gnome-utils.i386 1:2.8.0-5
    Remove: gnome-volume-manager.i386 0:1.1.0-5
    Remove: gnomemeeting.i386 0:1.0.2-8
    Remove: gnopernicus.i386 0:0.9.12-1
    Remove: gok.i386 0:0.11.8-1
    Remove: gpdf.i386 0:2.8.2-4.2
    Remove: gstreamer-plugins.i386 0:0.8.5-1
    Remove: gthumb.i386 0:2.4.2-5
    Remove: gtkhtml3.i386 0:3.3.2-3
    Remove: hwbrowser.noarch 0:0.20-0.fc3.1
    Remove: iiimf-gnome-im-switcher.i386 1:12.1-10.FC3
    Remove: k3b.i386 0:0.11.14-2
    Remove: kde-i18n-Chinese.noarch 1:3.3.1-1
    Remove: kde-i18n-Chinese-Big5.noarch 1:3.3.1-1
    Remove: kdeaddons.i386 0:3.3.1-1
    Remove: kdeartwork.i386 0:3.3.1-1
    Remove: kdebase.i386 6:3.3.1-4.3.FC3
    Remove: kdegraphics.i386 7:3.3.1-2.4
    Remove: kdelibs.i386 6:3.3.1-2.12.FC3
    Remove: kdemultimedia.i386 6:3.3.1-1
    Remove: kdenetwork.i386 7:3.3.1-3
    Remove: kdepim.i386 6:3.3.1-1.FC3.1
    Remove: kdeutils.i386 6:3.3.1-1
    Remove: krb5-auth-dialog.i386 0:0.2-1
    Remove: libbonoboui.i386 0:2.8.0.99cvs20040929-2
    Remove: libgail-gnome.i386 0:1.1.0-1
    Remove: libgal2.i386 2:2.2.5-1
    Remove: libgnome.i386 0:2.8.0-2
    Remove: libgnomeui.i386 0:2.8.0-1
    Remove: memprof.i386 1:0.5.1-5
    Remove: nautilus.i386 0:2.8.1-4
    Remove: nautilus-cd-burner.i386 0:2.8.3-6
    Remove: nautilus-media.i386 0:0.8.1-3
    Remove: openh323.i386 0:1.13.4-7
    Remove: openoffice.org.i386 0:1.1.3-11.5.0.fc3
    Remove: openoffice.org-i18n.i386 0:1.1.3-11.5.0.fc3
    Remove: openoffice.org-libs.i386 0:1.1.3-11.5.0.fc3
    Remove: planner.i386 0:0.12.1-1.1.fc3.rf
    Remove: pwlib.i386 0:1.6.5-11
    Remove: rhn-applet.i386 0:2.1.16-1
    Remove: rhythmbox.i386 0:0.8.8-2.1.fc3.rf
    Remove: sound-juicer.i386 0:0.5.14-1.FC3.0
    Remove: system-config-httpd.noarch 5:1.3.1-1
    Remove: system-config-network.noarch 0:1.3.22-1
    Remove: system-config-packages.noarch 0:1.2.20-1
    Remove: system-config-printer-gui.i386 0:0.6.116.1.4-1
    Remove: system-config-soundcard.noarch 0:1.2.10-1
    Remove: timidity++.i386 0:2.13.0-3
    Remove: up2date-gnome.i386 0:4.3.47-5
    Remove: vino.i386 0:2.8.1-1
    Remove: xsane-gimp.i386 0:0.92-13
    Remove: yelp.i386 0:2.6.3-1

    After it started removing several packages I recognised. But I did not know how to stop it.

    It tooks me more than 6 hours to install them one by one with
    # yum install package.

    To avoid the reoccurance of this mishap I started searching for RESTORE command in this respect. Otherwise I have to re-use "rpm -e package" in future instead.

    B.R.
    satimis

  8. #8
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    I think you tried to remove a package which other packages depended on, if so the removed packages probably would'nt functionate without the package anyway. And yes, if you use rpm -e you see if other packages depends on it, and which packages does. But I still think it would work with the Add/Remove progrms thought. Also, I beleve it could be done everything at once by typing this like in apt:
    Code:
    yum install package1 package2 package3 package4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •