Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
mine is set to generic ps/2 wheel and works fine. I cant get the 4th and 5th buttons workign but i doubt any programs have them set up for use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766

    mine is set to generic ps/2 wheel and works fine. I cant get the 4th and 5th buttons workign but i doubt any programs have them set up for use anyway tho.

  2. #12
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    Which file am I editing to put in the "Auto" and or "Logitec" ?

    Is it:
    XF86Config
    or
    XF86Config-4


    And after I save the edit changes how to I make the new changes take effect immeadiatly besides rebooting from the command line?

    ???

    Thanks,
    JB

  3. #13
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    The file you edit for this is located under /etc/X11 and are called XF86Config. To run the new parameters you just have to restart your X-session. That means logout from X and log in again.
    Regards

    Andutt

  4. #14
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    not quite andutt. Maybe in redhat, but the new mandrake ditro's (everythgin after 9.0 i think) use /etc/X11/XF86Config-4

    XF86Config is actually completely unnessescary now.

  5. #15
    Just Joined!
    Join Date
    Aug 2003
    Posts
    5
    I don't know if this helps but when i press the 3rd mouse button, it searches google for the phase tat i selected.

  6. #16
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    Ok...I was kind of wondering which file that needed to be edited. I've been messing with the XF86Config file....

    So from what Hellmasker is saying I should edit the XF86Config-4 file.

    Right now this file looks like this:

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    EndSection

    So should I try this: ??
    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "Logitech"
    Option "Device" "/dev/psaux"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"

    Or should I try something else...And if this messes up how do I recover if I'm unable to use the mouse after saving those settings?

    When I goto use "mousedrake" from the command line I see that PS/2 "Standard" is highlighted. When I chose PS/2 "Generic PS2 Wheel Mouse" and click "OK" my mouse pointer gets stuck up on the top part of my screen and I'm unable to control it?

    Thanks Hellmasker....
    JB

  7. #17
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    Ok,

    I tried what I posted and that didn't do anything.

    I then selected Generic PS/2 Wheel Mouse and that didn't work either. These are the settings now in the XF86Config-4 file..

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
    EndSection


    Should I change Protocol to Logitech?
    JB

  8. #18
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    OK,

    No I tried the Logitech MouseMan+ and this isn't doing it either


    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "MouseManPlusPS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
    EndSection

    What I really don't get, is that when I press down on the mouse wheel I can then push my mouse up or down and I get the scrolling effect. Yet I can't simply use my index finger to scroll the wheel backwards and forwards to get the same effect. So its working somewhat..

    I know that this is a trival matter and IT is totally stupid...But thats whats so frustrating..this was working and now all of the sudden the functionality is gone...This isn't the first time that strange crap like this has happened with MDK.
    But of course I'm sure its something that I'm doing wrong or should I say "not doing right" Hee..heee.. known ta do that...

    Any other words of wisdom at this point... I'll leave my mouse settings as they are for now unless someone thinks that they can offer anything else. Much appreciated everyone.

    On to shell/hell scripting now....
    JB

  9. #19
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I'm surprised that Mdk is still using the XF86Config-4 filename. It was only supposed to be used in the period of transition between XF86-3 and XF86-4.

    Anyway, did you try the "Auto" protocol?

  10. #20
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    It's working now..
    Here's the change that I made to the XF86Config-4 file..

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/psaux"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    EndSection


    Thanks everyone..
    JB

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •