Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Hello, I'm using ManDrake 9.0 with Gnome. I have a logitec optical mouse. Standard two buttons with a scroll wheel in the middle. So maybe thats a 3 button then... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113

    Mouse Scroll


    Hello,

    I'm using ManDrake 9.0 with Gnome.

    I have a logitec optical mouse. Standard two buttons with a scroll wheel in the middle. So maybe thats a 3 button then...

    Anywayys, what I'm trying to accomplish is when I'm on web pages I would like to be able to use the scroll wheel/button to scroll up and down on a web page instead of having to manually go over to the scroll bar on the left hand side and manuall move the scroll bar up and down.

    I read through some posts that said to add the line "Option "ZAxisMapping" "4 5" to the /etc/X11/XF86Config-4 file.
    I did this and rebooted and still don't have the funcitonality that I'm wanting. If I press down on the middle mouse wheel first I then have the ability to simply move the mouse up or down and then I get a similar scrolling funcitonality but I would like to be able to just use the wheel like I'm used to.

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "ZAxisMapping" "4 5"

    In Galeon, I've tried going to "Settings Preferences", "User Interface", "mouse" and choosing Auto Scrolling for the middle mouse button..... Still nothing..

    Can anyone help me out here..

    Thanks,
    JB

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    That is three buttons, so take out the emulate 3 buttons/timeout line. If that doesn't work, you might have to fiddle with the option protocol line. I have an intelimouse so I have to use IMPS/2 ; you might have to use something different.

  3. #3
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    Tried that and still a no go.

    I also tried using the IMPS/2 without any luck...The totally stupid thing is, is that this was working before I went and reinstalled linux..I don't remember doing anything different in my initial install setup.

    Go figure...

    Anyone else have any hints?


    Thanks,
    JB

  4. #4
    Just Joined!
    Join Date
    Aug 2003
    Posts
    5
    I would also like to know how to do this ^^. My first post =D
    just installed Mandrake 9.1 Yesterday and got my winmodem to work... feel so pround haha

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Is the mouse connected via PS/2 or USB? I'm guessing PS/2, but it depends on your configuration.

  6. #6
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    Hello Dolda,


    It's connected via PS/2..

    Thanks,
    JB

  7. #7
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    type mousedrake in a terminal and select either 2 btn ps2 standard + wheel, or mayeb the guy with the logitech mouse shoudl select the special logitech option, ive nenver used one of them so i dont know.

    my genius netscroll works with the ps2 2btn + wheel option but not woth the genuis netscoll option so im not sure how good those special drivers are.

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    If that doesn't work, try using the "Logitech" or "Auto" protocol. What mouse model is this?

  9. #9
    Linux Newbie
    Join Date
    Aug 2003
    Posts
    113
    Looking at the bottom of the mouse , it reads:
    Logitec
    Wheel Mouse
    M/N: M-BD58
    PIN: 830386-000

    Now one thing that I should mention is that this mouse had a USB connector that I fitted with a PS/2 adapter because the old computer that I had before didn't have USB support onboard. Sorry I didn't mention that before.

    Dolda said: "If that doesn't work, try using the "Logitech" or "Auto" protocol. What mouse model is this?"


    Where is it that I can find the selections that your talking about. "Logitech" or "Auto" protocol?

    When I choose "mousedrake" from the command line these are the choices:

    PS/2
    -----Generic PS/2 Wheel Mouse
    -----GlidePoint
    -----Logitec MouseMan+
    -----Standard (THIS IS THE SELECTION THAT I'M CURRENTLY USING)
    [+} Other
    ----Genius NetMouse
    ----Genius NetScroll
    ----Kensington Thinking Mouse
    ----Mircosoft Explorer
    USB
    -----Generic
    -----Generic 2 Button Mouse
    -----Kensington Thinking Mouse
    -----Mircrosoft Explorer
    Busmouse
    ------2 Buttons
    ------3 Buttons
    None
    -----No Mouse
    Serial
    ------Generic 2 Button Mouse
    ------Generic 3 Button Mouse
    ------Logitec MouseMan
    ------Microsoft IntelliMouse
    ------Mouse Systems
    [+] Other
    ----Genius NetMouse
    ----Kensington Thinking Mouse
    ----Logitech CC Series
    ----Logitech Mouse (serial, old C7 type)
    ----Logitech MouseMan+/FirstMouse+
    ----MM HitTablet
    ----MM Series

    Hope this helps. Oh yeah.. I can't remember which one of these that I tried before to get problem resolved, but I ended up choosing one that totally locked my mouse up into the upper righthand corner of the screen. So if that happens again I should just be able to pull up the command line and pull up mousedrake and fix correct?

    Thanks,
    JB

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Did you try the "Generic PS/2 Wheel Mouse"?
    Anyway, I though this was what you were already doing: Open /etc/X11/XF86Config, and the mouse section. There, you will find the Protocol option. You can change that one to "Logitech" or "Auto".

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •