Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I'm new into linux, installed Red Hat 7.0.1, installed web server and ftp (WU-FTPD) server. Web server works, FTP doesn't. the file /etc/xinetd.d/wu-ftpd comes (default with installation of package) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Location
    Portugal
    Posts
    4

    can't get FTP to work


    Hi, I'm new into linux, installed Red Hat 7.0.1, installed web server and ftp (WU-FTPD) server. Web server works, FTP doesn't. the file /etc/xinetd.d/wu-ftpd comes (default with installation of package) without a line "disable=yes", I've added a line "disable=no" and restarted the service by running: /etc/init.d/xinetd restart.
    can't ftp to that box, (ftp connection refused even from the same computer where the ftp server was supposed to be running)

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You shouldn't just add another line saying disable=no. Instead, replace the current disable line with "disable=no". If that wasn't it, then check if you have a firewall running, blocking port 21.

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Location
    Portugal
    Posts
    4

    FTP

    I've made a simple server installation from the red hat cd, selected individual packages web server and ftp server, no firewall. I only added the line because the line that *should* be there (disable=yes) wasn't there at all, which is strange... The linux box is connected on a small home network, I can ping it from another computer, I can see the web site from another computer, I cannot FTP from another computer or even from the ftp server and onto itself.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh, it did not have that line? I must have mis-read it from the beginning.
    What do the logs say? Restart xinetd and check the lgos for anything about wu-ftpd.

  6. #5
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Do you get any error in /var/log/messages ??
    Regards

    Andutt

  7. #6
    Just Joined!
    Join Date
    Sep 2003
    Location
    Portugal
    Posts
    4

    ftp

    no errors in log, xinetd starts ok. But I noticed the following, I reinstalled the system (to see if I had forgot any package) the result now is that when I give the command: ftp 172.16.0.3 (my internal network address) the message "connected to 172.16.0.3" appears but nothing else, it just gets stuck there (when connecting from the server itself or from another machine). However if I give the command (in the server): ftp localhost the ftp works...(?)

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It could be a hostname resolving problem. Are your DNS settings correct on the server?

  9. #8
    Just Joined!
    Join Date
    Sep 2003
    Location
    Portugal
    Posts
    4

    FTP

    Yes, it was a DNS problem, apparently. Thanks for the help. By the way the Red Hat 7.01 distribution I got didn't had the file /etc/xinetd.d/wu-ftpd with the line "disable = yes", only the 7.3 release I installed afterwards had, oh well... .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •