Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    "The Gentoo Way" see'ing linux with new eyes!!

    I'm writing to this forum in the hopes that I can get some resolution, insight, clarity and to vent in the hopes that someone understands and can possibly help symathize/empythize. Thus, it is a little long winded...but please take the time to readon and help get me on the right path I don't need allot of hand holding just some suggestions and some Wise Eyes.

    I have about 17 questions, that should, for the experienced users, should be very easy to see whats happening...I very much appreciate your time.

    Where am I coming from?
    Well, I'm not NEW to M$,trouble shooting tcp/ip indepth,and firewalling. Having used a product that has basically done everything for me,... M$... (background process,programs, kernel wise)....M$....has kept me at M$'s mercy. Looking to broadening my Horizons and breaking free from the almighty M$ beast. Eventually I would like to have a firm grasp and abiltiy to control my wild linux animal

    I have a friend at work that has (Gentoo linux) (At this point all linux distro's were the same in my mind..not knowing squat about linux at all) which had WEB,FTP,Firewall,DNS,MAIL,SAMBA file/print server, all on the same beefy box. I was very impressed, and most of all impressed with the fact that this was all FREE software. But I noticed one thing that kind-of made me cringe...(again not know anything about linux) he did most of his configuring via command line and editing config files with VI. Everytime he downloaded software it would compile each program and spit out strange looking stuff on the screen..scary looking.....


    .. coming from an OS/Kernel that not only does everything for you but is also GUI based has spoiled me rotten but at the same time has held me down to the M$ level. So watching him work with config files and here'ing all the linux buzz words...about compiling everthing from the source..ect..ect.. honestly intimidated me quite a bit. But I'm a rebel right...

    So I installed Linux Mandrake (on my friends suggestion), for the first time about 6 months ago. Started to get used to my new surroundings compairing to M$. All in all it was a pretty painless install experience. Booted off the CD, chose all packages , and suprisingliy, everything seemed to run smoothy. I could read cd's, listen to muisc,download email, whatch mpeg movies, print.....And the best part about it was that it was FREE software, did the simple things that I do with M$, and then-some, big-time...(THE IMPORTANT POINT HERE IS THAT MANDRAKE SEEMED TO DO EVERYTHING FOR ME AS WELLL....HEE.HEE...
    Cool, I'm liking this... didn't cost me a penny, doesn't crash on me or constantly and ask me to download security patch's on a daily basis. IMPRESSIVE!!!!!
    My very basic, basic, computer needs are met and I'm able to treverse around this new OS without much trouble. Getting a little more confident now,..... and wondering why I had never used linux before....

    Everything ws running smoothly until I started to tailor the system to my custom computer wants and software needs. Gaim..for IM'ing, Shorewall firewall for simple secuity and masq'ing to share our chinsey dialup line...
    Well running MDK 9.0 and needing to upgrade to 9.1 at this point wasn't a choice because downloading 2 gigs to get too 9.1 on a dialup is out of the question. But I needed all the new features that the new kernel and 9.1 offered...

    RPM cookers and RPM hell...And I mean HELL...Dependency this..Dependency that..But I didn't give up. After two weeks of getting no where, slowly lossing my sanity and Mandrake starting to fall apart because of the frustrated dimwhitted attempts at blindly doing anything/stupid things to get things to work, I got so frustrated that I wanted to cause my computer PAIN. I'm sure everyone knows what I'm talking about, most seem to anyway.. Most of all I wanted to scream at Linus if he could only here me....And whats the first thing I want to do,.....of course....go back to M$ a little baby..Yes, I admit it.

    I go back to my friend to let him know the madness that I'm going through and he suggested that I goto Gentoo. He did the best that he could to explain how Gentoo differs form the RPM based linux distro's and how this would solve allot of the RPM frustrations that I was going through and keep me up-to-date and unbloated with software that I only used an not everything else. I liked the sound of that. Matter of fact that sounded perfect...

    LiTTle did I know the journey that I embarked upon...

    He burned me two Gentoo CD's at work for my PIII arcitecture...and said to follow the install guide and do a stage3+GRP install because I had dialup. For the most part I followed this install guide to the letter. And to be honest I didn't really understand most of what I was doing while I was doing it, so this proves that the doc is for the most part well written. This is now a totally different universe than even Mandrake was.

    I can see that Mandrake (like M$ in a sense) did everything for me. I can see that Gentoo is just the oppisite. I have to tell it what I want it to do and how and when. UH..O...I can tell that I'm in for a ride now. So I'm doing my best to absorb the concepts and follow along. The man pages help very little for a noob but I do read them. Understanding what I'm reading is a whole different story. I'll get there though because I have stick-tuitiveness.

    My problem is that I don't understand allot of these initial base Gentoo concepts. And I've already messed some stuff up not knowing that I did. Everything is still working for the most part but I dare not go any further until I get some help. So this is the reason that I am asking for some clarity here..before I set myself up for failure..

    The CD came with Kernel-2.4.20-gentoo-r5 and I used Grub as my bootloader and Genkernel to compile the kernel.

    # emerge sync (this command is explained and the concept understandable)

    # emerge xfree (Understandable)

    # env-update && source /etc/profile (have no clue what this is doing but did it anyways)(I would like to know though) When do I know when to invoke this command?
    # rc-update add xfs default (not sure what this is doing but I'm assuming that this is needed before I can install KDE or GNOME or any other windowing/gui stuff..)(maybe this is telling the kernel to add xfee at bootup..again not sure exactly)
    # /etc/init.d/xfs start (not sure...)

    # startx (This is obvious)(Started Xfree server)3 ugly ass windows...see ya..ctrl<backspace>

    Then...the mouse...this is fine upto....
    Don't forget to add the modules that your mouse uses to modules.autoload.d/kernel-2.4.
    Code listing 2.10: Adding entries to modules.autoload.d/kernel-2.4
    # nano -w /etc/modules.autoload.d/kernel-2.4 (not sure what this file is used for and what I'm doing here..looks as though I'm telling the kernel to load hardware settings about my mouse and or other hardware that I have)
    # We will add the following lines to the file.

    I didn't add anything to this file because I didn't understand what they wanted me to add and why. I have a "IMPS/2" mouse and made the appropriate changes to the /etc/X11/XF86Config file. But my mouse buttons and scroll wheel work fine even after reboot.

    Make sure that "qt" and "kde" are in your USE variables in make.conf.
    Make sure that (optional) "-gnome" and "-gtk" are in your USE variables in make.conf.
    Now this is an area that really confused me even after reading the USE doc.. They give examples of what you put in thier and lead me to beleive that for every peace of software that I install that I should add the name here...Not to sure...even after reading the USE doc...I think some better examples would help maybe.

    Now the strange thing is that I didn't do anything as far as a video card and sound card configuration and these just seem to work. I don't know how so I just leave it alone for now. But eventually I would like to have Gentoo optimizing any features that these devices have.
    SoundBlaster Live adition Soundcard
    64M AGP ATI RADEON vid card.

    I eventually got Xfree and KDE installed using the Gentoo desktop doc. Again the guide was great because I didn't really understand allot of what I was doing but it seemed to work..COOL....

    Whoooo....Hooooo...some light at the end of the tunnel
    Configured net access with Kppp dialup utility and started to follow the Portage users doc to get my Gentoo upto date.

    Now this is where I think that I might of done something wrong.

    Updating Portage

    Before using our Portage tree, it's important that you update Portage by doing the following:
    Code listing 1.3: Updating Portage
    This will show you what packages are going to be updated
    # emerge -up system
    This will update the necessary packages
    # emerge -u system

    #emerge sync
    But the next part right after this command is where I need to get a better understanding:
    * NOTICE: PLEASE *REPLACE* your make.globals. All user changes to variables
    * in make.globals should be placed in make.conf. DO NOT MODIFY make.globals.

    * Feature additions are noted in help and make.conf descriptions. Update
    * them using 'etc-update' please. Maintaining current configs for portage
    * and other system packages is fairly important for the continued health
    * of your system.

    >>> Regenerating /etc/
    >>> Auto-cleaning packages ...

    >>> No outdated packages were found on your system.

    * GNU info directory index is up-to-date.
    * IMPORTANT: 3 config files in /etc need updating.
    * Type emerge --help config to learn how to update config files.

    bash-2.05b# etc-update
    Scanning Configuration files...
    The following is the list of files which need updating, each
    configuration file is followed by a list of possible replacement files.
    1) /etc/dispatch-conf.conf
    2) /etc/make.conf
    3) /etc/make.globals
    Please select a file to edit by entering the corresponding number.
    (-1 to exit) (-3 to auto merge all remaining files)
    (-5 to auto-merge AND not use 'mv -i'): -3

    Replacing /etc/dispatch-conf.conf with /etc/._cfg0000_dispatch-conf.conf
    mv: overwrite `/etc/dispatch-conf.conf'? y

    Replacing /etc/make.conf with /etc/._cfg0000_make.conf
    mv: overwrite `/etc/make.conf'? y

    Replacing /etc/make.globals with /etc/._cfg0000_make.globals
    mv: overwrite `/etc/make.globals'? y

    Exiting: Nothing left to do; exiting.
    I then did:
    #emerge -u world
    >>> /usr/src/linux-2.4.20-gentoo-r6/COPYING
    >>> /usr/src/linux-2.4.20-gentoo-r6/REPORTING-BUGS
    >>> /usr/src/linux-2.4.20-gentoo-r6/CREDITS

    * After installing a new kernel of any version, it is important
    * that you have the appropriate /etc/modules.autoload.d/kernel-X.Y
    * created (X.Y is the first 2 parts of your new kernel version)
    (I thought that this was created automatically when the kernel is compiled)
    So I check that directory to see whats listed.
    #ls /etc/modules.autoload.d/*
    /etc/modules.autoload.d/kernel-2.4 /etc/modules.autoload.d/kernel-2.5
    (Not sure what to do next so I do etc-update because this seems to be the standard operating proceedure after doing an upgrade or a sync. Please correct me if I'm wrong.

    bash-2.05b# etc-update
    Scanning Configuration files...
    The following is the list of files which need updating, each
    configuration file is followed by a list of possible replacement files.
    1) /etc/init.d/hdparm
    2) /etc/kernels/genkernel
    Please select a file to edit by entering the corresponding number.
    (-1 to exit) (-3 to auto merge all remaining files)
    (-5 to auto-merge AND not use 'mv -i'): -3
    (again..I chose -3 like I did last time. Still don't know exactly what I should be choosing or how to unfix what I've done the last two times.)

    Replacing /etc/init.d/hdparm with /etc/init.d/._cfg0000_hdparm
    mv: overwrite `/etc/init.d/hdparm'? y

    Replacing /etc/kernels/genkernel with /etc/kernels/._cfg0000_genkernel
    mv: overwrite `/etc/kernels/genkernel'? y

    Exiting: Nothing left to do; exiting.

    Now it looks as though I have a new kernel to compile but I don't know what steps SPECIFICALLY IN ORDER considering that I used Genkernel to compile last time. And what effects this is going to have on the software that I have emerged so far and exactly where the new kernel is actually located.

    All of these were loaded using standard "emerge <package name> as they are named below.
    xfee...this is working
    kde....this is working
    gaim...this is working
    ethereal..not working
    shorewall..not working
    Ethereal... Not sure whats happening with this one. (worked in Mandrake fine) I know that when I compiled this in Mandrake I had to have ethereal plus libpcap. And libpcap is installed and up-to-date.

    When I'm logged in as a normal user and type:
    bash-2.05b$/usr/bin/ethereal (not sure if I need to be root or normal user) Most times I try to run programs as Root Gentoo won't let me. Mandrake was never like this and matter a fact I thought thats how you needed to run most programs anyways..shows you what I don't know and where I'm coming from.

    Anyways, Ethereal opens but when I goto capture traffic I don't have any network interfaces to choose from to start capturing traffic. Eth0 (local lan) or PPP0 when I'm dialed up. Everythings plugged in and I can ping from eth0 to a Win98 machine and I can ping from ppp0 out to the internet. Im missing something small I'm sure..
    So I thought that I needed to be "su". This is what's spit out.

    bash-2.05b# /usr/bin/ethereal
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Gtk-WARNING **: cannot open display: :0.0
    bash-2.05b# exit

    When I emegre a package, how can I tell after I have emerged that package everything that was installed along with the specific package?

    Shoerwall firewall
    It looked like it install the iproute package and the neccessary modules but I'm unsure.

    when I issued the Shorewall "start" command this is whats spit out:
    bash-2.05b#shorewall start
    Starting Shorewall...
    Shorewall has detected the following iptables/netfilter capabilities:
    NAT: Not available
    Packet Mangling: Not available
    Multi-port Match: Not available
    Connection Tracking Match: Not available
    modprobe: Can't locate module ip_tables
    iptables v1.2.8: can't initialize iptables table `filter': iptables who? (do you
    need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.
    Processing /etc/shorewall/stop ...

    (I've obviously missed something here)

  2. #2
    Linux User
    Join Date
    Jun 2003
    Huntington Beach, CA
    Well that was quite the read, but I'll do my best to answer your questions:

    1. env-update updates the /etc/, which seems to be an ordered list of all the things installed on your computer. /etc/profile points your shell to new paths and updated binaries, whenever emerge is run and something is installed it automatically does /etc/profile. I'm not entirely sure myself the details of what these two commands do, but that's the basics.

    2. rc-update add xfs adds xfs to your start-up scripts, which tells it to load during boot up. Same thing with rc-update add eth0, rc-update add vcron, all tells the computer to load these things during boot up.

    3. /etc/init.d/xfs start started the XFontServer when you first installed it. This basically provides fonts to all things X.

    4. nano -w /etc/modules.autoload.d/kernel-2.4 edits the modules.autoload file for a 2.4 kernel. This file modprobes kernel modules at start up, like 3c59x (ethernet card module) and ide-scsi (scsi emulation). The mousedev, usbcore are modules needed for USB mice, but you're running on the PS/2 port, that's why your mouse and scroll wheel work fine without adding those.

    5. The USE flag sets keywords that any application being compiled will use. A lot of applications have special optimization options so the application can be built for specific things. Adding -gnome and -gtk will make any application with the option of compiling with -gnome and/or -gtk specifications compile the application with those settings. So no, you don't have to add USE flags for everything, in fact it's likely you wont have to add any. The Gentoo USE guide is very helpful, so if you want more information maybe give that another read.

    6. Seeing as you used genkernel, support for SB Live and the ATI RADEON was compiled into the kernel. When I compile kernels I have to be sure to add support for my SB Live and my vid card, otherwise they wont work.

    7. Don't worry about that, that's for special settings someone who really knew what they were doing would make. You also did the right thing by letting it automerge.

    8. You did the right thing, if you had selected no the things you updated would have remained the same.

    9. I'm not sure what genkernel does with modules or if it compiles modules. I'll look into it. Check in /lib/modules/kernelwhateverthenameis/kernel. If there are any modules installed, it will have them organized in that directory.

    10. Yes, do ect-update after an emerge sync. It overwrites the old with the new.

    11. I select 3 as well.

    12. I don't think you have to compile a new kernel. I think your existing one was just updated, but I don't use genkernel so I can't say for certain. I'm not sure what ethereal and shorewall is, sorry.

    13. What do you mean it by "wont let you run programs in root"? What exactly does it say? I also don't know anything about PPP0, someone else will have to field that one.

    14. Again, don't know about ethereal.

    15. I don't see a 15

    16. Do an emerge --pretend whatever, it will tell you , in order, the packages that will be emerged.

    17. Don't know about that one, don't use shorewall or any firewall for that matter. With Linux, I just don't see the need for it.

    Well I hope I've shed some light for you. I'm still a new Gentoo user myself, but I tried to answer these questions to the best of my ability. I tried my first install back at the begining of July I think, didn't get it right until about the middle. It has been quite the learning experience for me, and I'm still learning now. That's the thing I love about Gentoo, and Linux in general. Good luck with your future Gentoo/Linux endevors.

  3. #3
    Thanks for taking the time to give me some feed back. Sorry for being so long winded.

    About the Kernel upgrade?

    If I do a uname -a I still see that I'm using 2.4.20-gentoo-r5.

    bash-2.05b# cd /etc/modules.autoload.d/
    bash-2.05b# dir
    kernel-2.4 kernel-2.5
    bash-2.05b# ls -la
    total 12
    drwxr-xr-x 2 root root 136 Jul 26 15:10 .
    drwxr-xr-x 51 root root 3136 Sep 7 07:20 ..
    -rw-r--r-- 1 root root 0 Jul 26 15:10 .keep
    -rw-r--r-- 1 root root 571 Jul 26 15:10 kernel-2.4
    -rw-r--r-- 1 root root 470 Jul 26 15:10 kernel-2.5
    How do I tell if this is an upgrade or a fullon new kernel?

  4. $spacer_open
  5. #4
    Linux Engineer
    Join Date
    Jan 2003
    Lebanon, pa
    You will probably have to configure/compile a kernel manually in order for shorewall to work since it looks like it is missing some modules it needs to work correctly. The 2.5 kernel is a devel kernel, you are currently using the lastest stable kernel for gentoo so don't worry about 2.5. You do not need to run etc-update after an emerge sync since that just does an rsync to some server to mirror /usr/portage. etc-update just scans /etc for config files waiting to be merged.

  6. #5

    I got the kernel upgraded successfully from 2.4.20-gentoo-r5 to r6.

    I've figured out a work around to get ethereal to work. Next time I won't post several problems in the same post. Sorry about that. This was purely out of frustration and will try not to let that happen again.

    Thanks everyone

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts