Find the answer to your Linux question:
Results 1 to 4 of 4
I busted my serial keyboard by spilling soda all over the thing last week, and it went unfunctional. So naturally the first thing I did was purchase a new keyboard. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542

    New Keyboard... Doesn't work


    I busted my serial keyboard by spilling soda all over the thing last week, and it went unfunctional. So naturally the first thing I did was purchase a new keyboard. They don't make serials anymore, so I bought a Belkin USB keyboard. I loaded the SUSE 9.3 install cd into the drive and booted to it, but the keyboard didn't work. I rebooted, and it still didn't work. It worked fine in Windows XP though... I tried booting to a DOS bootdisk... then realized that the keyboard doesn't function in pure DOS. I tried the old serial keyboard (which was strangely now somewhat functional... the caps lock and numlock keys don't work though) and it worked just fine in the SUSE install cd and DOS mode. I think this has something to do with the fact that the old keyboard is serial. So I'm using the old keyboard now, with limited functionality, but I don't want to use the new one unless there's a way to get it to work in an older/non-hdd based os. Any suggestions?!

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Have you tried enabling "Legacy Support for USB Devices" in your BIOS? That helps me sometimes.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Have you tried plugging in both and running YaST to install the USB board? What do you get from
    Code:
    dmesg
    when you plug in the USB keyboard?

  4. #4
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542
    Quote Originally Posted by techieMoe
    Have you tried enabling "Legacy Support for USB Devices" in your BIOS? That helps me sometimes.
    It worked! Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •