Here's what I did to enable disk quota for my users on my Linux system->
I have Red Hat Linux 4.2 (kernel 2.0.30)
I did all usual steps to enable quota:
1.Quota support in kernel
2.Modified /etc/fstab:
/dev/hda1 / ext2 defaults,usrquota,grpquota 1 1
3.As user root, I did create manually the files "user.quota" + "group.quota" within the root directory
of the file system that will have quota enabled.
Then, gave rw permissions to root over bith files.
4.Initialized "quota.user" and quota.group files with "edquota" ->
I did "edquota -u user1", then vi open with following contents:

/dev/hdb1: blocks in use: 0, limits (soft = 0, hard = 0)
inodes in use: 0, limits (soft = 0, hard = 0).
But I got error "cannot save file" when I
want to change the updated infos. why?
5.I did put quota scripts in my /etc/rc.d/rc.sysinit (so that quota would be enable at bootup :
# Check quota and then turn quota on.
if [ -x /usr/sbin/quotacheck ]
then
echo "Checking quotas. This may take some time."
/usr/sbin/quotacheck -avug
echo " Done."
fi
if [ -x /usr/sbin/quotaon ]
then
echo "Turning on quota."
/usr/sbin/quotaon -avug
fi
But When I rebooted my system for the changes to take effect, my system would not
pass the boot up process. It jams there:
..............
..............
Turn on user and group quota for local filesystems
quotaon: using quota.users on /dev/hdb1: read-only fs
Check quota .....
/proc must be mounted a different way in /etc/fstab
.............
Init: Id xx (where xx are the different init levels number): Id "x" respawning
too fast --disabled for 5 mins
........
Cannot open read only file systems
...........

And it would stop there at boot up