Find the answer to your Linux question:
Results 1 to 3 of 3
My Red Hat Linux system has already quota enabled (when it boots, it says "turning on quota for root filesystem") ->I did set my partition /dev/hdb2 to be mounted on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    15

    To disk quota experts


    My Red Hat Linux system has already quota enabled
    (when it boots, it says "turning on quota for root filesystem")
    ->I did set my partition /dev/hdb2 to be mounted on /home
    ->I did Edit /etc/fstab with:
    /dev/hdb2 /home ext2 defaults,grpquota 1 1
    ->I created " quota.group " and gave it rw permissions for root.
    ->I have several users that are member of the group " users"
    and want to assign disk quota limitation (group " users" exist in
    /etc/group). So I did " edquota -g users ":
    quota for group users
    /dev/hdb2: blocks in use 2500000, limits (soft = 1500000, hard = 2000000)
    inodes in use: 0, limits (soft = 0, hard = 0)
    -> Then I did run " quotaon -a"
    But the limit quota still does not apply to my group (when I type "quota -g users",
    I get " Disk quota for group users (gid 100): none).
    Same problem, even after I rebooted my system.
    Everything done through these steps were done as user root.
    RedHat Linux version 4.2
    Kernel 2.0.30
    Diskquota version dquot_5.6.0

  2. #2
    Just Joined! drdelaney's Avatar
    Join Date
    Feb 2007
    Location
    IL
    Posts
    16
    In order to impliment quotas, you need to use the quotacheck command, you cannot simply create a file called quota.group. I did the same thing back when I first started learning about quotas

    Basically once the grpquota option is enabled in /etc/fstab and you do a reboot or mount -o remount /home, you will need to run the following commands
    # turn quota off, if on
    quotaoff /home

    # in your case, remove the quota.group file as its 'corrupt', or not made correctly
    rm /home/quota.group

    # create the new file, initialize the guota.group file
    quotacheck -cgvm /home # create. group, verbose, do not remound ro.
    # add a u if you wish to enable user quotas as well

    # note: it will throw some warnings about not finding old group file, this is ok
    ls -la /home/ # should show your group quota file, and possibly user if created

    # turn quotas back on
    quotaon /home

    # recreate group quota
    setquota -g users 1500000 2000000 0 0 /home

    # check quotas
    quota -g users # should show the new quotas


    These commands are taken from a newer redhat system, but should be close to what you need. If you get any errors about invalid options, try running "man setquota" or whatever program provided the error.

    Hope this helps!

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Urm... this thread is over 4 years old so any response is not likely to help the OP.

    Locking...
    oz

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •