Find the answer to your Linux question:
Results 1 to 3 of 3
That's weird! After the lappy lasted working for 4 hours, i could see a process named kacpid running there, it takes about 80% performance of CPU. Worse that was, there ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    NJ
    Posts
    6

    kacpid takes 80% performance of CPU,ARGH!


    That's weird! After the lappy lasted working for 4 hours, i could see a process named kacpid running there, it takes about 80% performance of CPU. Worse that was, there were many errors flashing on the screen when i was trying to shutdown the box, though it could shutdown automaticly at last, log file /var/log/messages would become very large, it nearly took 5 minutes to open it integrated.
    well, any one suffering the same issue with me? or any idea to fix it will be greatly appreciated!!!

  2. #2
    Linux User
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    401

    Uhmm... ACPI broken?

    It seems you have a broken ACPI implementation... the problem is not the software, but your platform... maybe...

    ACPI specification was implemented gradually... maybe you can take in consideration to use APM instead ACPI... you should remove all ACPI support from kernel to enable APM management...

    This should works...

    Another solution is to disable ACPI power management using the kernel parameter "noacpi". This should disable the kernel thread kacpid...
    When using Windows, have you ever told "Ehi... do your business?"
    Linux user #396597 (http://counter.li.org)

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    1

    kacpid takes most system resources and constantly runs hard drive

    Take this with a grain of salt because I’m an absolute Linux beginner, but I had the same problem with Xandros Desktop 4 Professional (on a new eMachines, P4, 1.5 Gb, SATA, NTFS, Vista preinstalled computer) and the following worked for me: I reinstalled Xandros but omitted “KDE3 Supplemental” from the install process and the problem was gone. The description of “KDE3 Supplemental” in the Xandros installation program indicates that , at least for users who are not part of a LAN, it doesn’t do anything you would miss. There were various other solutions proposed on Linux websites but I wasn’t knowledgeable enough to understand them, grub?, debug?, what!?

    Caveats:

    1) Don’t waste your time contacting Xandros Installation Tech Support, they don’t have a clue. If, like me, you purchased Xandros you paid your $80.00 for nothing (although I do really like Xandros). Accept it as a lesson and go on. I came up with what worked for me using the old tried and true try-this-and-if-it-doesn‘t-work-try-that method of problem solving;

    2) since this was an intermittent problem with my computer and sometimes Xandros worked fine and “kacpid” didn’t eat up 98% of my system resources I’m not certain this is a permanent solution, but so far so good; and

    3) I have no idea if this is a workable solution for Linux builds other than Xandros but the problem was frustrating enough for me that I wanted to pass on what worked for me and was fairly simple to implement in case it would work for somebody else who, like me, is mystified by Linux esoterica.

    Steve8072@msn.com

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •