Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm running RH9.0 and need to install the new up2date in order to update the system. I have the file : up2date-3.1.23.2-1.i386-rpm I have tried to run this in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2003
    Posts
    1

    Redhat Updater Problem


    Hi,
    I'm running RH9.0 and need to install the new up2date in order to update the system.
    I have the file :
    up2date-3.1.23.2-1.i386-rpm

    I have tried to run this in root and normal user, by double clicking, but it disappears after checking for dependencies.

    I have tried to run it in root and normal user using the command :

    ./up2date-3.1.23.2-1.i386-rpm

    but it says checkk permissions. So I run this command :

    chmod -x up2date-3.1.23.2-1.i386-rpm

    But then get the error when running ( ./up2date-3.1.23.2-1.i386.rpm ) :

    cannot execute binary

    Any help will be much appreciated, thanks!

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    rpm -Uvh package.rpm is how you install rpms.

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Actually rpm -Uvh upgrades packages but installs them if they dont exist. rpm -ivh only installs.
    Regards

    Andutt

  4. #4
    Just Joined!
    Join Date
    Oct 2003
    Posts
    19

    I know what prob is

    I had the same prob with mine. Its an easy fix it took me about 45 min of pulling my hair out but the rhn page lies to u in a way. You have cd into the directory you put the files to run the verify and to run the rmp

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •