Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, Hope that somebody can help me. I am trying to create a linux rescue boot cd. I am using Slackware ver10, Kernel 2.6.12.2 and isolinux version 3.09. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    3

    Initial RAMdisk not working properly


    Hi,

    Hope that somebody can help me. I am trying to create a linux rescue boot cd. I am using Slackware ver10, Kernel 2.6.12.2 and isolinux version 3.09.

    I have compiled kernel with Initrd, ramdisk and so on support. I used Mkisofs to create iso and configured isolinux.cfg to boot my initrd and kernel. The cd boots perfectly, it finds the kernel and the initrd file and says loading bzimage and loading robinit (my initrd file)

    It gets to the point, where it says RAMDISK: ext2 filesystem found at block 0
    RAMDISK: loading 16384kib (1 disk) into ram disk...done
    VFS: Mounted root (ext2 filesystem)
    Freeing unused Kernel memory: 372kb freed
    Init: version 2.84 booting
    Init: Cannot execute "/etc/rc.d/rc.S"
    Init: Entering runlevel: 3
    Init: Cannot execute "/etc/rc.d/rc.M"

    If I use the intrd.img file that I downloaded from the Slackware website, the system boots perfectly and I can login and do whatever. With my Initrd file, I cannot login using any account or password and I cannot get the rc.S and rc.M files to execute. I cannot get anything to execute. I am not sure whether my Linuxrc file is even being executed. I believe that it has the correct execute permissions. Its in the root directory of the initrd file. I have put several echo statements in, none of which come up on the screen. I believe that my problem is something to do with the root file system (either the real root file system or the root file system used by the initrd file), is not being found by the system and hence it cannot execute anything.

    If I omit the line root=/dev/ram0 in isolinux.cfg file, I will not get the Init file booting. I get a kernel panic and message cannot find the root file system, please append the correct "root=blah blah" statement. Now I don't know if the /dev/ram0 is pointing to the real root file system or the one used by the initrd file itself.

    i can give you the contents of my innittab, fstab, linuxrc, isolinux.cfg files if you think it will help. I have read loads of documentation from various websites and cannot work out exactly what is wrong with my setup. Just out of interest, my initrd file requires the root=blah blah to be set in isolinux.cfg file. The slackware initrd file does not.

    Many thanks

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Posts
    3

    Update

    Determined that the problem was my linuxrc file was not being run. Fixed that and a host of other problems. Still have a couple of problems, nothing serious, bar one. I still cannot login. I get to the login prompt and put in my username and password. It says incorrect login. I tried various passwords, blank passwords etc, nothing works. cannot use bootcd until I can get logged in. Ideally speaking, I don't want a login at all. Its a rescue disk, not something containing important data. Obviously I have missed out a file that is required for the user account information. I have copied the obvious ones like shadow, password, and group. But there must be another file(s) that is needed. Would appreciate any help on this. The only other main issue, is for some reason, my bootmsg is not displayed at boot time. It shows the isolinux screen and the boot prompt. I then type 2 which is the label I use for the netcd. Why can't I get my bootmsg file to display. I have tried specifying a direct path to it in the isolinux.cfg file and changing the permissions. Nothing works. Any ideas

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    3

    Closing Query

    I have managed to get the login to work properly after many hours spent. It required the libnsscompat** files for the login to work.
    I have still not got the boot message to display, but will make a new post for that as it is a isolinux query and not to do with the ram disk.

    I am now closing this query as problem has for the most part been resolved

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •