Find the answer to your Linux question:
Results 1 to 2 of 2
I have decided that it is time to learn how to deal with dependency issues during installation, and I figured I would install gnome 2.4. I understand this is an ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Albany,NY
    Posts
    5

    Installing new versions of libraries


    I have decided that it is time to learn how to deal with dependency issues during installation, and I figured I would install gnome 2.4. I understand this is an enourmous task and hoped it would be so I could learn.

    Problem (time to learn): I ran into a problem after I installed the first package (libxml2). That installation seemed to go fine, but when I tried to "./configure" the next package (libxslt) it told me that i needed the version of libxml2 2.5.6 or later and I was using the version 2.4.23 . The great search for the answer to why it didn't update to the new version was on and I had deduced that I needed to run ldconfig. I did this, and still configure was recognizing the old version. I tried moving the new libraries into my /usr/lib from the /usr/local/lib directory and removed the old libraries to a back up directory and ran an ldconfig because I though that might have been the problem.
    After all of this the ldconfig output is now :

    libgcj.so.3 -> libgcj.so.3.0.0
    libg2c.so.0 -> libg2c.so.0.0.0
    libopcodes-2.13.90.0.2.so -> libopcodes-2.13.90.0.2.so
    libbfd-2.13.90.0.2.so -> libbfd-2.13.90.0.2.so
    libxml2.so.2 -> libxml2.so.2.5.11

    …………………a ton of other listings…………….

    libswigtcl.so -> libswigtcl.so
    libusb-0.1.so.4 -> libusb-0.1.so.4.1.1
    libdb_tcl-4.0.so -> libdb_tcl-4.0.so
    libxsltbreakpoint.so.1 -> libxsltbreakpoint.so.1.0.8
    libxslt.so.1 -> libxslt.so.1.0.19
    libexslt.so.0 -> libexslt.so.0.7.10
    libgnomecanvas-2.so.0 -> libgnomecanvas-2.so.0.0.0
    libglade-2.0.so.0 -> libglade-2.0.so.0.0.0
    libbonobo-2.so.0 -> libbonobo-2.so.0.0.0
    libgconf-2.so.4 -> libgconf-2.so.4.1.0
    libbonobo-activation.so.4 -> libbonobo-activation.so.4.0.0
    libxml.so.1 -> libxml.so.1.8.17
    libgdk_pixbuf_xlib-2.0.so.0 -> libgdk_pixbuf_xlib-2.0.so.0.0.6
    libgtk-x11-2.0.so.0 -> libgtk-x11-2.0.so.0.0.6
    libgdk_pixbuf-2.0.so.0 -> libgdk_pixbuf-2.0.so.0.0.6
    libgdk-x11-2.0.so.0 -> libgdk-x11-2.0.so.0.0.6


    After another failed attempt to "./configure" libxslt I decided to post here to see what you guys thought. According to the ldconfig all is well and I am NOT getting link errors or anything. Although configure is not complaining about libxml would it be interfering with the lixml2 version? Am I missing something very obvious? Any help would be much appreciated.

    Also, is there a good exmple or tutorial for updating libraries? I went to xmlsoft.org and read all of their material on the packages, and read all of the documentation in the package (which is perfectly identical) ,plus searched like crazy on the internet but, all of the documentation is horrifically vague.

  2. #2
    Just Joined!
    Join Date
    Jun 2003
    Location
    Albany,NY
    Posts
    5
    OK ....

    Well, either no one has any idea OR

    My description and/or question was not clear enough.....

    ANY kind of feed back at this point either way would be nice.

    -Thank You

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •