Find the answer to your Linux question:
Results 1 to 3 of 3
This is a strange problem that I spent all yesterday trying to figure out. I've been running Fedora Core 4 for a month or so now, no problems at all. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    btr
    btr is offline
    Just Joined!
    Join Date
    Oct 2005
    Location
    N.H., USA
    Posts
    6

    tcsh seg faults when home dir is an nfs mount


    This is a strange problem that I spent all yesterday trying to figure out. I've been running Fedora Core 4 for a month or so now, no problems at all. When I came in Monday monday morning my session was still live and all of my open xterms were still ok, but I couldn't start any new ones, nor could I telnet in. I restarted my X session and couldn't get in anymore, even under failsafe. I could login as root, though.

    This is as far as I could narrow it down:
    - From a root prompt, I couldn't su to my own username.... I would just get a root promt again (later discovered that tcsh was crashing with a segmentation fault.)
    - when I changed my shell (chsh) to something other than tcsh (csh is linked to tcsh), I could su to my username, but I could not run tcsh from there (segmentation fault)
    - when logged in as root, I could run tcsh just fine.
    - my home directory is normally NFS mounted from a central file server. When I replace it with a "real" local directory, then tcsh doesn't have any problem. I've tried chaning the way nfs mounts the directory (automount vs. hard mount, etc) but none of that makes a difference. There's nothing wrong with the mount, though... I can see/access all files & directories ok, no delays or network errors.
    - tried rebooting, but no improvement
    - tried removing my .tcshrc & .login, no improvement
    - the system /etc/csh.cshrc and /etc/csh.login files are executed to completion before the seg fault occurs.

    The only things I can identify that may have changed between Friday (when everything was fine) and Monday was:
    - On Friday I was using CPAN.pm to install a bunch of modules and had to ctrl-C out of it rather abruptly. I was running this as non-root and installing everything into ~/perl so I'm assuming I didn't inadvertantly stomp on anything.
    - Fedora's up-to-date program installed some updates over the weekend:
    Oct 21 04:40:32 Updated: ethereal.i386 0.10.13-1.FC4.2
    Oct 21 04:41:27 Installed: kernel.i686 2.6.13-1.1532_FC4
    Oct 21 04:41:32 Updated: ethereal-gnome.i386 0.10.13-1.FC4.2
    Oct 21 04:44:31 Installed: kernel-devel.i686 2.6.13-1.1532_FC4
    Oct 22 05:42:44 Updated: java-1.4.2-gcj-compat.i386 1.4.2.0-40jpp_31rh.FC4.2
    Oct 22 05:43:10 Updated: gimp-help.noarch 2-0.1.0.9.0.fc4.1

    The stuff on Oct 21 happened before I had any problems, but I can't see how updating java and gimp-help could have anything to do with it. Installing a new kernel version? I don't know enough to be able to tell whether that would make a difference, but the system had not rebooted.

    I'm about to reinstall/repair to clear out anything. If anyone has any ideas, I would appreciate it.

    Thanks.

  2. #2
    scm
    scm is offline
    Linux Engineer
    Join Date
    Feb 2005
    Posts
    1,044
    The pain of using something as awful as csh and tcsh. Why not use a proper shell, like Korn?

  3. #3
    btr
    btr is offline
    Just Joined!
    Join Date
    Oct 2005
    Location
    N.H., USA
    Posts
    6
    I'd say that programming in any shell language is painful. But as a shell, I actually like tcsh a lot.

    I figured out my problem though.... the .history file was corrupted somehow and caused the shell to segfault when it tried to load it.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •