Find the answer to your Linux question:
Results 1 to 4 of 4
hi this is my first post on this site i have a single boot system using grub and Fedora Core 4 which has been installed for a few months. however ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Location
    York, England
    Posts
    2

    Possible corrupted kernel? stops after grub


    hi
    this is my first post on this site

    i have a single boot system using grub and Fedora Core 4 which has been installed for a few months. however it has suddenly begun to freeze at the same point when loading the kernel (i think):

    grub comes up ok, i select fc4 and instead of printing loads to screen as it loads fc4, it just displays the following text and does nothing else:

    Booting 'Fedora Core (2.6.11-1.1369_FC4)'
    root (hd0,0)
    Filesystem type is ext2fs, partition type 0x83
    /vmlinuz-2.6.11-1369_FC4 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    [linux-bzImage,setup 0x1e00, size=0x18e473]

    can anyone please help me track down the source of this problem as i have been unable to do so by myself. i have not added any hardware, and tweaks to the bios settings make no difference.
    i tried restore mode from the fc4 cd and was successful in logging in on a console as root, but simply don't really know what to do next.

    my computer is:
    amd athlon 2500 (clocked at 2.2ghz)
    abit nf7 botherboard (nforce2 chipset)
    onboard lan/sound/usb etc.
    1 x 512mb twinmos ram (400mhz)
    agp asus geforce fx 5600

    i vaguely remember that i used "halt" or "shutdown" to shut it down, would that have caused the problem? i haven't had any probs before
    can anyone confirm that it is at this point that it loads the kernel? could it be a corrupt kernel thats freezing it?
    if so is it easy to replace the kernal? could i just backup and replace /boot/vmlinuz-2.6.11-1369_FC4 with an "uncorrupted" version or is it not as simple as that? i have an nvidia display driver which i think updates the kernel.

    all ideas and assistance will be appreciated and i can of course provide more details if needed.

    thanks for any help

    James

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542
    Try updating the kernel. If that doesn't work then post back here and we'll try some more drastic measures.

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Location
    York, England
    Posts
    2

    some test results...

    Hi. thanks for the response

    i did some investigation using the grub command console and found out the following:
    -> it is the "kernel" command which freezes
    -> with the "same" kernel (retrieved from the fedora cd using a windows rpm extractor, same name, exact same size), the "kernel" command worked, but when "boot" is called, it restarts the computer immediately! oh dear!

    the following leads me to believe that its a corruption / hard disk problem:
    -> i CAN rename the broken kernel file (After all, that wouldn't require the computer to read the file)
    -> i CANNOT copy it, it freezes in the same way
    -> when i use cmp to compare it with the kernel off the cd, it lists some differences then does the same thing, it freezes
    -> there was a grub command called something like "testload" and i did that with the kernel files. the broken one: it froze halfway, with the other kernel: it finished ok.

    do you think this conclusion is correct?
    do you have any idea how i should go about fixing it?
    its wierd how the other kernel doesn't work either.

    Hope this is all clear (i'm not very good at explaining things)

    Thanks for the help
    James

  4. #4
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    fsck the filesystem from a live CD or floppy GNU/Linux OS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •