Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
Thanks bryansmith, I edited /etc/fstab to include what you had down. I still can't change the ownership of lowellgrippo, no matter if as root or regular user... olishes_colt_45_acp:...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    Thanks bryansmith,

    I edited /etc/fstab to include what you had down. I still can't change the ownership of lowellgrippo, no matter if as root or regular user... olishes_colt_45_acp:
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #12
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Dapper Dan,

    After making the changes I suggested, did you check to see what the ownership was already set it? You shouldn't have to change anything - it should mount with the UID/GID ownership you specified in the fstab.

  3. #13
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    Try changing the ownership of the directory the filesystem is mounted on recursively.

  4. #14
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by anomie
    Dapper Dan,

    After making the changes I suggested, did you check to see what the ownership was already set it? You shouldn't have to change anything - it should mount with the UID/GID ownership you specified in the fstab.
    I expected to see that the files ownership had changed to dapper:users after the changes. It didn't. What I did was unmount it, made the changes, then remounted it and all files were still under root:root.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #15
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by a thing
    Try changing the ownership of the directory the filesystem is mounted on recursively.
    It won't let me do that either. I went:
    Code:
    chown -R dapper:users /media/wd_fat_1
    and every file inside comes up: Operation not permitted! :drown:
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #16
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    Try umounting the drive and changing the permission of the directory its mounted on.

    /me wonders why mtab isn't in /var...

  7. #17
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Hmmm...this is a doodle of a melon scratcher. Have you tried chmod? Give:
    Code:
    chmod 777 <filename>
    just to see at least if you can change it this way.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #18
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405
    Why is this taking so long?

    The filesystem is vfat. Vfat does not support file ownership settings; it's designed for DOS/Windows. When you use a vfat file system in *nix, all files and directories are owned by whatever userid/groupid is specified at the time of mounting (i.e. in the fstab).

    You simply can't change ownership of individual files/directories with vfat.

    I've never bothered changing ownership from the defaults of root:root. Putting a umask of "000" in the fstab gives full access to all users, which is all I want. If I wanted security, I wouldn't put it on vfat in the first place.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  9. #19
    Just Joined!
    Join Date
    Oct 2005
    Location
    North Carolina, USA
    Posts
    45
    Right, if you want permissions/ownership on a drive shared with DOS/win, I think you need umsdos, which lets you specify gid and uid in fstab.

  10. #20
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by IsaacKuo
    Why is this taking so long?
    It wouldn't have if you'd jumped in sooner.
    You simply can't change ownership of individual files/directories with vfat.
    Can /etc/fstab be changed to change the ownership of all the files? Or will the ownership always be root:root?
    If I wanted security, I wouldn't put it on vfat in the first place.
    I detest vfat and normally would never use it. This is an experiment to see if configuration files can be accessed from Linux and Windows for the same application running under each. I'd rather not have to open the application as root.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •