Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I've got Debian 3.1 testing with a KDE desktop but I can't get out of that desktop to any console. The usual Ctrl-Alt-F# doesn't work, although my desktop works ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225

    No TTYs, can't Ctrl-Alt-F# !


    Hi,
    I've got Debian 3.1 testing with a KDE desktop but I can't get out of that desktop to any console. The usual Ctrl-Alt-F# doesn't work, although my desktop works normally.

    My login manager is kdm, although I usually go with gdm, i'm trying kdm out. WHen it first starts, before I log in, I can Alt-N and that kills the kdm and returns me to the first console. However, if I press Alt-F2, Alt-F3 etc I get blank screens.

    I don't think this is a fearture of kdm. I think this has to do with setting tty numbers or something somewhere, but I don't know where.

    Can anyone help?

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    In your /etc/inittab have you got lines like:
    Code:
    c1:12345:respawn:/sbin/agetty 38400 tty1 linux
    c2:12345:respawn:/sbin/agetty 38400 tty2 linux
    c3:12345:respawn:/sbin/agetty 38400 tty3 linux
    c4:12345:respawn:/sbin/agetty 38400 tty4 linux
    c5:12345:respawn:/sbin/agetty 38400 tty5 linux
    c6:12345:respawn:/sbin/agetty 38400 tty6 linux
    (this is what creates the VT's at boot). You could always see if you can start one with
    Code:
    /sbin/agetty tty1
    etc.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    yeah, I've got them, but they're /sbin/getty instead of /sbin/agetty.

    When I tried one manually all I got was the usage print out with more options than you can shake a stick at, I tired a few (including the one you just suggested) but same result.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    My inittab entries are as follows:

    1:2345:respawn:/sbin/getty 38400 tty1
    2:23:respawn:/sbin/getty 38400 tty2
    3:23:respawn:/sbin/getty 38400 tty3
    4:23:respawn:/sbin/getty 38400 tty4
    5:23:respawn:/sbin/getty 38400 tty5
    6:23:respawn:/sbin/getty 38400 tty6

    What do you think?

  6. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    Thumbs up [QUOTE=humbletech99]My inittab entries are as follows:

    Quote Originally Posted by humbletech99
    My inittab entries are as follows:

    1:2345:respawn:/sbin/getty 38400 tty1
    2:23:respawn:/sbin/getty 38400 tty2
    3:23:respawn:/sbin/getty 38400 tty3
    4:23:respawn:/sbin/getty 38400 tty4
    5:23:respawn:/sbin/getty 38400 tty5
    6:23:respawn:/sbin/getty 38400 tty6

    What do you think?
    Hi
    had exact same as this - added the missing 45 to each line and rebooted - got all ttys back

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •