Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I have just installed SuSE 9.0 and want to setup my machine as a test server for our website. We backup the website on a windows file server periodically. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2003
    Posts
    5

    Root unable to modify permissions


    I have just installed SuSE 9.0 and want to setup my machine as a test server for our website. We backup the website on a windows file server periodically. I have logged onto our file server with samba and pulled across the backup file. I have configured apache and am ready to roll. The only problem is that even when logged on as root I am unable to modify the permissions for the files. They are currently owner: root, group: users. Any clues? I am a bit of a Linux newbie but even so I thought root could do anything!

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    How were you trying to modify the permissions, were you using the chmod and chown commands? Are you sure you were attempting the commands as root?

  3. #3
    Just Joined!
    Join Date
    Nov 2003
    Posts
    5
    I was definately logged in as Root on KDE using konqueror to modify the permissions.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Run it from console and see what error is.

  6. #5
    Just Joined!
    Join Date
    Nov 2003
    Posts
    5
    I have managed to modify the permissions.

    I have partitioned my dual boot machine (win2k/linux) with an additional "data" drive (formatted in Fat32). This drive is mounted in linux at "/windows/D". I am unable to modify the permissions when the file is held on this partition. When I copied the files to a linux partition there was no problem.

    This is probably very obvious to some but I don't really understand the proble. I know that linux permissions do not transfer directly to windows but I didn't realise that I would not be able to change the permissions at all.

    Does the mount point, "/windows", have a special significance? On another of my dual boot machines I have a similar setup with a Fat32 data drive mounted at "/data" writable too by both windows and linux. I do not have the same problems with this machine.

  7. #6
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    The mount point doesn't matter. What's the line in your /etc/fstab look like for that mount?

  8. #7
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    If the files are stored on fat32, you cannot change the permissions. You can use mount options like uid=<blah> and guid=<BLAH>,umask=<blah> to set initial permissions when it is mounted. The defualt permissions is current owner of the mount process.

  9. #8
    Just Joined!
    Join Date
    Nov 2003
    Posts
    5
    I've changed things around a bit but the problem still remains the same. I have my FAT32 data drive mounted at /data which I can write to as root but I cannot change the permissions. A user can read /data.

    My fstab looks like this

    /dev/hda2 / reiserfs defaults 1 1
    /dev/hda1 /boot ext2 defaults 1 2
    /dev/hda6 /data vfat defaults 0 0
    /dev/hda5 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbdevfs /proc/bus/usb usbdevfs noauto 0 0
    /dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
    /dev/fd0 /media/floppy auto noauto,user,sync 0 0

  10. #9
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    You should read my last post again.

  11. #10
    Just Joined!
    Join Date
    Nov 2003
    Posts
    5
    Thanks Genlee

    I was a bit confused about your post as I had believed that my previous configuration used a FAT32 data partition which I had been able to write to. After digging out the docs I see that it was in fact EXT2. Is there anyway to share a data drive that can have its permissions changed?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •