Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all im new to this whole linux thing and i just installed 'Navyn OS' on my side computer. Everything seems ok, till i get this: *Starting local... mount: special ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7

    Mount: Special Device /def/fd0 Error


    Hi all im new to this whole linux thing and i just installed 'Navyn OS' on my side computer.

    Everything seems ok, till i get this:
    *Starting local...
    mount: special device /dev/fd0 does not exist
    *failed to start loca.

    *Error: Problem starting needed service.
    * "splash" was not started.

    then it all like: This is localhost.(none) (linux i686 2.6.9-gentoo-r9) 19:02:57
    and i can log in, but i dont know how to fix whatever this problem is.

    i also noticed a thing in red when the computer was starting up saying: "you need to set /etc/hostname to a valid hostname"

    im not sure if that is the cause of this problem.

    I had read that maybe it was my fstab file, which i figured out how to view but have no idea how to edit it. here is what it is set to:
    /dev/hda1 / ext3 noatime 0 1
    /dev/hda5 none swap sw 0 0
    /dev/cdrooms/cdrom0/mnt/cdrom iso9660 noauto, users,ro 0 0
    #/dev/cdrooms/cdrom0/mnt/dvdrom udf noauto, users,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto, users 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    tmpfs / tmpfs defaults 0 0

    Any help on this problem will be greatly appreciated. thank you

  2. #2
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    Do you have a floppy drive on your computer? Sounds like it's looking for one that physically isn't there. You can use a program like vi, vim, emacs, or nano to edit the file, like so:

    Code:
    vi /etc/fstab
    vim /etc/fstab
    emacs /etc/fstab
    nano -w /etc/fstab
    One of those is bound to work. If I were you, I'd just take out the entire line about /dev/fd0. A wierd thing I noted about your fstab file is that normally one would see something like /dev/fda0 instead of just /dev/fd0. Looks like some of the spacing is out of whack. Just make sure every different category in your fstab is spaced properly, etc etc.
    --Dachnaz [Fuzzy Llama]

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366

    Re: Mount: Special Device /def/fd0 Error

    Quote Originally Posted by sdsurfer
    /dev/fd0 /mnt/floppy auto noauto, users 0 0
    take the "auto" out of this line, reboot, simple as that...

    Operating System: GNU Emacs

  4. #4
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112

    Re: Mount: Special Device /def/fd0 Error

    [quote="genesus"]take the "auto" out of this line, reboot, simple as that.../quote]

    Taking that out will make it unable to mount if the drive does exist... That option is under the filesystem column, and the argument 'auto' will have the Linux system try to automatically detect the file system. It's useful for floppies and other ejectable media. This 'auto' has nothing to do with mount options. 'noauto' makes the device not be automatically mount at boot, when it would be normally. There's no such argument as 'auto' in this column.
    --Dachnaz [Fuzzy Llama]

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7
    ok i changed the fstab table to:
    /dev/fd0 /mnt/floppy noauto noauto, users 0 0

    and i got this error instead:
    mount: fs type noauto not supported by kernel

    anything?

  6. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    ****...didn't see the simple type, do this instead

    Code:
    /dev/fd0     /mnt/floppy     auto     noauto     0 0
    Now if you can manaully mount it with this, then you can add the user option, not users...

    Code:
    /dev/fd0     /mnt/floppy     auto     noauto,user     0 0
    This way a normal user will be able to mount the disk...p.s. remember there is only a comma with no space between noauto and user

    Code:
    fstab howto
    /device     /mountdirectory     fstype     option1,option2,etc   0 0
    the last two 0s are dump variables, read up before changing them
    Operating System: GNU Emacs

  7. #7
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    To see if you have a floppy drive and that is supported in your kernel type:
    Code:
     dmesg | grep fd
    Amongst other info a line like:
    Code:
    Floppy drive(s): fd0 is 1.44M
    will appear.
    I\'m so tired .....
    #200472

  8. #8
    Just Joined!
    Join Date
    Dec 2005
    Posts
    7
    dudes sorry i didnt get back to you sooner. I got this crazy cold and then have been doen massive finals.

    so yeah i tryed that code and i get this new message now:

    mount: /dev/fd0 is not a valid block device

    AKA: thats what you get for not turning me on in like 2 weeks

    anything?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •