Find the answer to your Linux question:
Results 1 to 9 of 9
Hi there, I have two vfat drives mounted on my linux machine. I have the read/write permission for those drives only when i log in as the root, not when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    30

    problem in mounting vfat drives in read/write mode


    Hi there,

    I have two vfat drives mounted on my linux machine. I have the read/write permission for those drives only when i log in as the root, not when i log in as a normal user. I have given the user and rw options in fstab file, but i dont get the read/write permissions. All you linux pros out there please help me. My fstab file looks like this

    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda5 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/hda1 /drivec vfat auto,users,exec,dev,suid,rw,sync 0 0
    /dev/hda2 /drived vfat auto,users,exec,dev,suid,rw,sync 0 0

  2. #2
    Banned
    Join Date
    Jul 2004
    Posts
    947
    i am sure there is a umask setting
    google or man it
    i am not on a linux pc, i am at colleg, but i belive that is the problem
    it is like

    umask=**** where *** is a number

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    30
    Quote Originally Posted by the_guy_dressed_in_black
    i am sure there is a umask setting
    google or man it
    i am not on a linux pc, i am at colleg, but i belive that is the problem
    it is like

    umask=**** where *** is a number
    Sorry, i have no idea what you are talking about. What is umask?

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: problem in mounting vfat drives in read/write mode

    Quote Originally Posted by tnlg102
    I have given the user and rw options in fstab file, but i dont get the read/write permissions.
    That's because the "user" who mounted the drive is root. What if you replace the 'user,rw' with 'defaults' like your Linux drives? I think that will fix it.
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    30

    Re: problem in mounting vfat drives in read/write mode

    Quote Originally Posted by drakebasher
    Quote Originally Posted by tnlg102
    I have given the user and rw options in fstab file, but i dont get the read/write permissions.
    That's because the "user" who mounted the drive is root. What if you replace the 'user,rw' with 'defaults' like your Linux drives? I think that will fix it.
    Sorry that did not help. Actually i used to have default options earlier, but i couldnt get r/w permissions that is why i changed them. Just to be sure i changed the options back to default but it did not work. Please help!

  6. #6
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Try adding umask=0002 to the mount options.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  7. #7
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    zer0ed77 got his to work from this post using these options: vfat user,rw,owner,umask=000 0 0
    /IMHO
    //got nothin'
    ///this use to look better

  8. #8
    Just Joined!
    Join Date
    Dec 2005
    Posts
    30
    Thank you drakebasher, your suggestion worked.
    Linux forums rocks

  9. #9
    Just Joined!
    Join Date
    Jul 2005
    Location
    INDIA
    Posts
    41

    Mounting

    # mkdir /mnt/FAT

    # mount /dev/hda1 /mnt/FAT

    This is solve your Problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •