Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have a Red Hat Linux release 9 (Shrike) machine with X Server (XFree86 Version 4.3.0) and window manager as fvwm (FVWM version 2.4.19). My system boots into runlevel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Location
    Bangalore
    Posts
    10

    Disabling apmd during boot


    Hello,
    I have a Red Hat Linux release 9 (Shrike) machine with X Server (XFree86 Version 4.3.0) and window manager as fvwm (FVWM version 2.4.19). My system boots into runlevel 3 (id:3:initdefault) and I am calling startx from my .bash_profile. I did not wanted to see my screen going blank if I keep the machine idle for a long time so I disabled "dpms" and screensaver options inside .xinitrc-fvwm script.

    Let me just summarize...

    Operating System:
    [root@bulls root]# cat /etc/redhat-release
    Red Hat Linux release 9 (Shrike)

    XServer:
    [root@bulls root]# XFree86 -version
    XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
    Release Date: 27 February 2003
    ......

    Window manager:
    [root@bulls root]# fvwm -version
    FVWM version 2.4.19 compiled on Sep 30 2004 at 20:30:39
    with support for: ReadLine, Stroke, XPM, GNOME WM hints, Shape, SM, Xinerama

    .xinitrc-fvwm contents:
    [root@bulls root]# cat .xinitrc-fvwm
    #FvwmScript-ScreenSetup,1449
    #ScreenMark
    xsetroot -solid "#0EC4B8"
    xset s 0 0 s blank
    xset -dpms
    #end

    Now my problem is, if I keep my system idle for a long time (for 3 to 4 hours) the XServer doesnot response immediately if I try to move the mouse cursor or if I try to click on some buttons. The display takes few seconds to respond, then it becomes normal. This behaviour occurs only for the first time, then the system comes back to normal speed. This goes on in a cycle(Again if I leave the machine for some time period...).

    I did not wanted to see this behaviour.

    After doing some R&D I had a belief that apm is creating this situation. So, I disabled both ACPI and APM in my grub.conf file(appended "apm=off acpi=off" at kernel line). Here is my grub.conf(comments ommitted)

    [root@bulls root]# cat /boot/grub/grub.conf
    ....
    default=0
    timeout=10
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz

    title Red Hat Linux (2.4.20-8custom)
    root (hd0,0)
    kernel /boot/vmlinuz-2.4.20-8custom ro root=LABEL=/ quiet vga=788 splash=silent apm=off acpi=off
    initrd /boot/initrd-2.4.20-8custom.img

    But in BIOS->Power Management Setup->ACPI Function is Enabled. After booting I tried to see if apmd is running or not.

    [root@bulls root]# ps -aef | grep apmd
    root 909 787 0 12:33 pts/0 00:00:00 grep apmd

    So, apmd is not running and if I run "apm"...

    [root@bulls root]# apm
    No APM support in kernel

    After completing all these steps I left the machine idle for more than 8 hours(whole night), and then in the morning I tried to click on some buttons, surprisingly I DIDN'T SEE ANY KIND OF DELAY.(Sorry for shouting!!).

    My machine is not a laptop.

    I am looking for some more suggestions, please provide me. Did I followed the right steps? Is there anything more to be done? Sorry for the lengthy explanation.

    Please give me some more ideas so that I can try to finish this immediately.

    Thanks
    Seran

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908

    Re: Disabling apmd during boot

    To disable the "apmd" service so it doesn't start when your system boots, as root do:

    chkconfig --del apmd
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •