Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I've got my Redhat Linux 8.0 running in either runlevel 3 or 5. I leave the server alone for about 5 - 10 minutes, I come back, turn on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12

    Help! RH 8.0 Linux screen blank - connection lost!


    I've got my Redhat Linux 8.0 running in either runlevel 3 or 5. I leave the server alone for about 5 - 10 minutes, I come back, turn on the monitor, and wouldn't you know it - the screen has been "blanked" (no screen saver). During the time that the screen is "blanked," I can't access any network services (web server, webmin, etc.). Once I return to the "physical" terminal and move the mouse, the screen "unblanks" and seems to restore everything, and I can then remotely access services for another 5 - 10 minutes.

    I am super frustrated people. Any ideas?? Please? I will thank you forever!


    Vock Viel

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Probably you have a hardware bug in your motherboard. See if it's related to the console blanking with this procedure:

    1. Log in at a virtual terminal (text mode one, _not_ X, telnet or any other pty)
    2. Run "cat"
    3. Type in these keys (ie. keyboard keys, not characters), _exactly_:

    <ESC> [ 9 ; 0 ] <RETURN>

    4. Type CTRL+D to exit cat and log out.

    That issues the escape (hence the escape key) sequence to disable console blanking, so see if it still stops after that.

  3. #3
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12

    Doesn't seem to work...

    Thank you very much, but it didn't seem to help...
    I typed everything after entering cat, (one line, right?)
    and I think I did it right...

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You wasn't suppose to type it exactly as it said, but interpret it as the keys to press, ie. first you press the escape key, then the [ key, and so on. I thought you misinterpreted it, since you asked if it should be one line, even though I included the enter key.

  5. #5
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12

    Check..

    ok, so after I log in and run cat, then commands, it will look EXACTLY like this?:

    [root@localhost root]# cat
    ^[[9;0]

    [root@localhost root]# logout

    login:

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yeah, that's basically it. Did it help?

  7. #7
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12
    No blank screen anymore, but internet/web still cut off. When I turned on the monitor at the login screen and pressed a key, the following message came up:

    TLAN: eth0: Starting Autonegotiation
    TLAN: eth0: Autonegotiation complete
    TLAN: eth0: Link Active
    eepro100.c

    Maybe this is the problem?

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It would almost seem like your NIC enters some powersave mode or something (which seems really stupid, but it still seems like it). Run "modinfo -p eepro100" and post what it returns.

  9. #9
    Just Joined!
    Join Date
    Feb 2003
    Posts
    12
    debug int, description "debug level (0-6)"
    options int array (min = 1, max = , description "Bits 0-3: tranceiver type, bit 4: full duplex, bit 5: 100Mbps"
    full_duplex int array (min = 1, max = , description "full duplex setting(s) (1)"
    congenb int, description "Enable congestion control (1)"
    txfifo int, description "Tx FIFO threshold in 4 byte units, (0-15)"
    rxfifo int, description "Rx FIFO threshold in 4 byte units, (0-15)"
    txdmacount int
    rxdmacount int
    rx_copybreak int, description "copy breakpoint for copy-only-tiny-frames"
    max_interrupt_work int, description "maximum events handled per interrupt"
    multicast_filter_limit int, description "maximum number of filtered multicast addresses"

  10. #10
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Try shutting down apmd
    /etc/init.d/apmd stop

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •