Hi there everyone.

I have a big problem with Kingston Data Traveler 2 Plus 512MB Pen Drive.

When i attached it it was succesfully detectec but i was unable to mount it.

when i tried like that:
# mount -t vfat /dev/sda1 /mnt/usb
it told me: device not configured OR device busy

so i deleted the main partition on this Pen Drive and created new one with type fat and i still was unable to mount it.

i deleted the partition again and created a new one in Winsh!t XP with FAT type and later with FAT32 type but...

when i created these partitions on Winsh!t XP Pen Drive is no more detectable under linux ;/

no kernel messages, dmesg|grep mass gives nothing

it only works fine wunder this sh!t Winslows XP

I want to make this Pen Drive to be detectable and mountable under linux but i dont know how ;(.

i'm searching for winslows partition software to delete this partition on Pen Drive but i even cant find any good software which would be able to delete this partition. the built in disk management from Winslows XP is not able to delete it.

HELP people.

i run out of ideas how to make this work ;(

------------------------------------------------------------------------

A little step forward

i deleted the existing partition from the Pen Drive with Paragon Partition Manager 7.0. since there is no partition there it is fully detectable under knoppix by kernel but... i do not know which type of FAT create there to made it accesable from winslows XP and Linux.

hope u can help me...