Find the answer to your Linux question:
Results 1 to 3 of 3
Hi folks, Have a newly partitioned HD with following config; root@ttyp0[knoppix]# fdisk -l Code: Disk /dev/hda: 40.0 GB, 40020664320 bytes 255 heads, 63 sectors/track, 4865 cylinders Units = cylinders of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814

    Mounting problem


    Hi folks,

    Have a newly partitioned HD with following config;

    root@ttyp0[knoppix]# fdisk -l
    Code:
    Disk /dev/hda: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1   *           1          13      104391   83  Linux
    /dev/hda2              14          77      514080   82  Linux swap
    /dev/hda3              78        1415    10747485   83  Linux
    /dev/hda4            1416        4865    27712125    5  Extended
    /dev/hda5            1416        2510     8795556   83  Linux
    /dev/hda6            2511        3485     7831656   83  Linux
    /dev/hda7            3486        4216     5871726   83  Linux
    /dev/hda8            4217        4865     5213061   83  Linux
    without OS installed.

    /dev/hda5, /hda6/, hda7 and /hda8 all have data files. All partitions can be mouted previously on running Knoppix 4.0 LiveCD.

    An hour before ran Knoppix 4.0 to browse Internets and have some files saved on /dev/hda8. Those files were not download on Internet. Just copied some text/information from Internet on existing files on /dev/hda8. The PC/Knoppix LiveCD worked without problem and was turned off later.

    Now after turning on the PC and starting Knoppix LiveCD it was found /dev/hda8 could not be mounted.

    root@ttyp0[knoppix]# mount /dev/hda8 /mnt/hda8
    Code:
    mount: wrong fs type, bad option, bad superblock on /dev/hda8,
           or too many mounted file systems
    Other partitions can be mouted without problem. The data/files on them can be read.

    Please advise how to fix this problem.

    TIA

    B.R.
    satimis

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    You might want to pass the -t option with mount so for example with a fat32 filesystem:
    Code:
    mount -t vfat /dev/hda8 /mnt/hda8
    Also in knoppix there are usually Hard Drive icons on the desktop which you can view if you click on them - have you tried this approch? (note you might have to RightClick and then 'Mount').

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,814
    Hi dylunio,

    Tks for your advice.

    It was not the problem of the flag. There was some wrong in the partition concerned. Problem solved by running
    # fsck.ext3 device

    Knoppix can mount a partition by just running;
    mount /mnt/hdax

    B.R.
    satimis

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •