Find the answer to your Linux question:
Results 1 to 5 of 5
dmsg output: root@Grep:~# dmesg | grep CD-RW hdd: SONY CD-RW CRX145E, ATAPI CD/DVD-ROM drive Vendor: SONY Model: CD-RW CRX145E Rev: 1.0b i have this in my lilo.conf: append="hdd=ide-scsi" /etc/fstab info: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Posts
    7

    Problems with mounting cd in 2.6.0


    dmsg output:
    root@Grep:~# dmesg | grep CD-RW
    hdd: SONY CD-RW CRX145E, ATAPI CD/DVD-ROM drive
    Vendor: SONY Model: CD-RW CRX145E Rev: 1.0b

    i have this in my lilo.conf:
    append="hdd=ide-scsi"

    /etc/fstab info:
    /dev/sr0 /mnt/cdrom2 iso9660 noauto,owner,ro 0 0

    I have scsi cdrom support enabled as module and
    scsi emulation support enabled on ATA/ATAPI/MFM/RLL section in the kernel
    source.

    This is what happends when i try to mount the cdrom2:
    root@Grep:/mnt# mount cdrom2
    mount: /dev/sr0 is not a valid block device

    And the same with /dev/scd0.

    When i mount with device /dev/hdd:
    mount: wrong fs type, bad option, bad superblock on /dev/hdd,
    or too many mounted file systems
    (could this be the IDE device where you in fact use
    ide-scsi so that sr0 or sda or so is needed?)

    I'm fully able to burn cd with cdrecord 2.0.1 on the same device (0,0,0)
    Anyone that knows whats wrong?

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Try to mount it something like

    mount -t iso9660 /dev/hdd /mnt/cdrom2

    and see what happens..

    Good luck

  3. #3
    Just Joined!
    Join Date
    Dec 2003
    Posts
    7
    Didn't work out.

    returned: mount: wrong fs type, bad option, bad superblock on /dev/hdd,
    or too many mounted file systems
    (could this be the IDE device where you in fact use
    ide-scsi so that sr0 or sda or so is needed?)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try not using scsi emulation. It is a nasty module and no longer needed to burn.

    http://www.this_site_does_not_exist/...highlight=scsi

    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #5
    Just Joined!
    Join Date
    Dec 2003
    Posts
    7
    Thanks.
    For others: I just removed "append="hdd=ide-scsi" " from my lilo.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •