Find the answer to your Linux question:
Results 1 to 6 of 6
hi, so i got winXP and Rh Linux 9 i can boot to xp with bootmagic, but when i wanna boot linux, it says like, "preparing machine to boot linux" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    23

    booting with bootmagic


    hi,
    so i got winXP and Rh Linux 9
    i can boot to xp with bootmagic,
    but when i wanna boot linux, it says like, "preparing machine to boot linux"
    and is stays like that... wich means it probably wouln't boot to linux



    so, for XP i chose the firstpartition (selected) (and the last one is my backuppartition)
    for linux i used pri 2 and 3 and none of 'em work ... the keep saying "preparing machine to boot linux"

    now when i first installed linux i was using the linux boot thingie, but with that i couldn't boot to winXP ...
    so i used my bootmagicdiskette, to start XP again, then tried to boot to linux again wich didn't work, then winXP again and now i'm here writing this post to you all, (yes i tried google 'n stuff)

    so if someone knows something ... help is welcome

    owyeah, i also saw something about "unhiding partitions" or something when i used the bootmagicdiskette

    and when i use the linux bootdiskette, i push enter and it says, "loading vmlinuz...." and then "could not load ...... please insert disc" ...

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    i dont think it will work that way because linux has no boot info stored anywhere but on mbr, which u just overwrote. I have had both linux bootloaders loading xp, try that again and psot up any problems u have.

    to get the linux bootloader to come back put in your install cd and get to a rescue console. if u need help with this, again, post back here.

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    May I ask why you don't want to use a Linux boot loader like LILO or GRUB?

    In any case, see if your system works correctly by doing this:
    1. Go to my home page (link at bottom of post)
    2. Download rawrite.exe and grub.img from it (under the "Useful files" section)
    3. Use rawrite.exe to write grub.img to a discardable floppy
    4. Boot from that floppy
    5. Enter these commands (enter after each):
    Code:
    root (hd0,2)
    kernel /boot/vmlinuz<Press TAB here> root=0303 ro
    initrd /boot/initrd<Press TAB here>
    boot
    If everything works as it should, RedHat should now be booting. If then you decide to use GRUB instead, just open a terminal, become root by running "su -", and run the command "grub-install /dev/hda".

  4. #4
    Just Joined!
    Join Date
    Jan 2004
    Posts
    23
    Code:
    Kernel panic&#58; No init found. Try passing init = option to kernel.

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh yes... there is something weird with RedHat's initrd that causes this, if I recall correctly.

    Try using only this command instead:
    Code:
    configfile /boot/grub/grub.conf
    That should use RedHat's GRUB configuration instead.

  6. #6
    Just Joined!
    Join Date
    Jan 2004
    Posts
    23
    you the man

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •