Find the answer to your Linux question:
Results 1 to 2 of 2
I am running Fedora Core 4 and have set up GmailFS on my computer to create a filesystem based on my gmail account. I have followed all of the directions ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4

    Accessing GmailFS mount as a nonroot user


    I am running Fedora Core 4 and have set up GmailFS on my computer to create a filesystem based on my gmail account. I have followed all of the directions as closely as possible, and I can successfully mount/view my directory as root.

    As soon as I try and view the directory as a normal user however, it doesn't even treat it as a directory. When it is successfully mounted and viewable as root, a dir by a normal user shows:
    ?--------- ? ? ? ? ? GmailFS

    for my mount. The mount command shows it as mounted:
    /dev/fuse on /mnt/GmailFS type fuse (rw,nosuid,nodev)

    I have checked all the files I can think of, fusermount, mount.gmailfs, gmailfs.py and the device /dev/fuse and all have world read and/or execute permissions set as appropriate. I have been unable to find any other reference to this problem.

    Thanks
    Nathan

  2. #2
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    Have you tried this...

    ...it worked for me.

    Assuming mount point is "/mnt/gmail":

    Code:
    chown root:fuse /mnt/gmail
    chmod 755 /mnt/gmail
    Also, make sure that the entry in /etc/fstab has the "user" option, so that ordinary, non-root, users can mount/umount the device.

    e.g.
    Code:
    /usr/share/gmailfs/gmailfs.py /mnt/gmail gmailfs noauto,user 0 0
    This entry assumes that "/etc/gmailfs/gmailfs.conf" exists and has appropriate configuration (rather than specifying username etc in /etc/fstab).

    Then, as a user who is part of the "fuse" group (may need to edit "/etc/group"):

    Code:
    mount /mnt/gmail
    After that, the user who did the mount should be able to read/write to the mounted gmail account.

    Have fun,
    Jono

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •