Find the answer to your Linux question:
Results 1 to 3 of 3
Recently I downloaded a copy of kstars 0.9.1 but to my surprise, when I made the ./configure --prefix=/usr (following the instructions) and I tried to run make then a few ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2002
    Location
    Panama
    Posts
    15

    Make error with Mandrake 8.1


    Recently I downloaded a copy of kstars 0.9.1 but to my surprise, when I made the ./configure --prefix=/usr (following the instructions) and I tried to run make then a few lines appeared with the following message I translated (because I have a spanish version):

    ***no rule found to build object 'index.doc.book', needed to 'index.cache.bz2'. high

    and then it goes (the message) out of all directories with the following messages (abreviated)

    *** [all-recursive] Error1
    [all-recursive] Error2

    I have Disk 1 and 2 of Mandrake, I made an installation of every library needed to run the program
    xfree86 , libqt2, kdelibs, libpng, libjpeg, libfam, zlib, all of them with -devel stuff. also I installed whatever you could imagine to run the make, automake, autoconf, but always the same trouble.

    any clues? maybe I did not install a rpm package that is causing this trouble. if I run

    xmkmf -a

    it display the same message that there are no rules.

    thanks for all the help

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    you will have to post this on a website concerned with kstars, it is too specific to help with more than just generally around here. The best I could tell you is to read the Makefile in that directory, see if you can find the "index.cache.bz2" line, and/or the index.doc.book line. You might be able to compile without these with --disable-doc or something like that. Try reading ./configure --help to see what parameters you are able to pass to configure. If a --disable-doc is available, try that
    I respectfully decline the invitation to join your delusion.

  3. #3
    Just Joined!
    Join Date
    May 2002
    Location
    Panama
    Posts
    15

    Thanks wassy!

    I e-mail Jason Harris at kstars@30doradus.org and submitted all this information about the problem. He told me that index.docbook is one of the documentation files, and that 'make' did not find the file, it must be located in a directory on the kstars tree, but it was not included in my tar file I just downloaded from one of the sites . He even told me that I could delete de doc directory when it must be and then 'make' should be able to get from there. but it did not work. So that is the point when your ideas came to play I was browsing the Makefile and I saw some lines that I could possible disable to try again. I also take a look at the
    ./configure --help you suggested to try and I found very interesting options.

    The Makefile has very, very interesting shell scripts and other stuff that remember me Unix.

    thanks again, when I get success I will post the solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •