Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
great then! i'll have to try this sometime, but not too soon. i don't want to mess my system up especially when our final examinations is so near and we ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User
    Join Date
    Aug 2003
    Posts
    289

    great then!

    i'll have to try this sometime, but not too soon. i don't want to mess my system up especially when our final examinations is so near and we have tons of project to do. don't want to work on that win98 that's occupying at least 3.2GB of valuable hard disk space. hehehe.. .
    Registered User #345074

  2. #12
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    Well I did the upgrade to Fedora core 1. The install/ upgrade was simple enough. The only problem that I encountered was with my NIC. It took some time and some google searches, OK a lot of google searches before I put in the right question, but all is well now as I am sending this post from my new Fedora box.

    If you have a 3Com 3c905x NIC and are thinking about installing/upgrading to fedora, I would sugest readding - https://bugzilla.redhat.com/bugzilla....cgi?id=102685
    The basics are
    " Additional Comment #9 From Dan Gennidakis on 2003-11-11 23:55 -------

    This is a Kudzu related problem with some of the 3com 905 based
    cards. Versions of Kudzu before 1.x are ok therefore Redhat 9 and the
    previous 2.1 Ent products are ok. If you turn of kudzu for the boot
    runlevel (chkconfig --level 345 kudzu off) and reboot; your nic will
    initialize fine and work. I downgraded kudzu to the RH 9 based
    version 0.99.x and the card is fine after booting (mind you
    downgrading dependency hell but I just went back up for testing).
    This has been a problem since Fedora test1 and in Fedora core 1
    release and in the Redhat AS and WS 3.0 line. Too bad it's not fixed
    yet. So currently just keep kudzu off at boot time unless you have
    added or changed hardware settings."

  3. #13
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    Here's a follow-up to the 3Com NIC problem that I had.

    This comes from http://fedora.artoo.net. I haven't tried it out, yet. But it's something.



    Q: My 3com network card doesn't work!
    A: Okay, first, look at this bugzilla bug. There are known problems with the 3Com 3c905B/TX and how it interacts with kudzu.
    If you want to disable kudzu (which detects when you have new hardware) this will resolve the issue for now. As root, in a Terminal, type chkconfig kudzu off -- after you reboot, your card should work. (Thanks to jroysdon for pointing this out.)

    I personally have worked around these problems with the following process. Note that this process is probably not reccomended by Red Hat, since it uses non-standard drivers. If you use PCMCIA (those laptop cards), this may cause you trouble.

    You must have kernel-source installed for this to work. Check the "Add/Remove Applications" tool in System Settings on the red-hat menu.
    Download Donald Becker's netdrivers to your home directory.
    Open a Terminal
    Do cd ~;mkdir netdrivers;cd netdrivers
    Unzip the netdrivers using tar -xzf ../netdrivers*.
    Compile them using make CC="gcc32"
    Become root.
    Do make install.
    Restart your computer, but watch out for kudzu. That means that if a blue-and-red screen comes up asking you something about 3Com, say "IGNORE"
    That may resolve your problems. It also may eat all the cheese.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •