Find the answer to your Linux question:
Results 1 to 6 of 6
I have an old Pentium 233 machine with a 3com NIC connected to a Linksys BEFW11s4 which is then connected to a cable modem. I have 2 other machines on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    13

    Redhat 9 Can't Connect to Internet


    I have an old Pentium 233 machine with a 3com NIC connected to a Linksys BEFW11s4 which is then connected to a cable modem.

    I have 2 other machines on the same network, a Tibook via Airport and a PowerMac 6500 via ethernet. They both access the internet flawlessly.

    I can conenct to both Macs from the Linux box but the browser in Redhat 9 just won't connect to the internet. I CAN use the Redhat browser to connect to the BEFW11S4's setup page so I know that the http is being sent OUT of the Linux box, it's just not making it past the Linksys to the internet.

    Any ideas?

    P.S. I'm a newbie....

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    make sure that ur DNS servers are listed in /etc/resolv.conf and that ur gateway is set to the ip of the linksys-whatever router

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    1

    can't connect to web sites on the internet

    Hi,

    I too have RH9 recently installed, but I cannot get mozilla to connect to websites on the internet. My W2k machines on the saem network connect fine so I know in theory evrythong should just work - even with the Linux PC I can connect to my dlink DSL box, so my local IP connectivity is fine.

    I have checked resolve.conf, and I do see the correct DNS server addresses that come from my ISP via my DSL modem. I am using a wireless connection, and as I say, IP to the DSL box is OK.

    I did notice that there does not appear to be a means to enter a default gateway (192.168.0.1 in my case) for the wifi interface (eth1), unlike what you see on the wired ethernet interface (eth0) when using the net config tool "system settings->network". I have disabled the eth0 wired interface since I do not use it.

    My assumption is that I cannot resolve DNS names to IP addresses, and this may be because the wifi interface cannot communicate through the gateway because it has no means to know where to direct DNS queries to. I can ping everything on the local network, but cannot ping well-known external IP addresses....

    So the question is, how do I specify a gateway address for the wifi interface ?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    route add inet 192.168.0.1 (insert gateway ip here) i think this is the rightw ay round, maybe inet comes before add

    or edit /etc/sysconfig/network

    and add the line
    GATEWAY=192.168.0.1 (again replace with ur gateway ip)

  6. #5
    Just Joined!
    Join Date
    Jan 2004
    Posts
    13
    Wow, that's all it was!! I set my gateway to the IP assigned to the router by the cable modem and I'm working!!!

    Thanks guys.

  7. #6
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    route add default gw <ip-address>
    should do the trick.
    Fixing Unix is better than working with Windows.
    http://nikhilk.homedns.org/projects/index.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •